Main menu

Navigation

Bug CESM1.2.0 when using branch with BRNCH_RETAIN_CASENAME=TRUE

3 posts / 0 new
Last post
hannay
Bug CESM1.2.0 when using branch with BRNCH_RETAIN_CASENAME=TRUE

I believe there is a bug in CESM when you set a branch run with BRNCH_RETAIN_CASENAME=TRUE
(Note this only happens when BRNCH_RETAIN_CASENAME=TRUE. I can run if I change the casename but I would like to keep the same casename).

To demonstrate the problem, I did a very simple experiment.
I ran a 5-day run. Then I branched from the end of the run with BRNCH_RETAIN_CASENAME=TRUE
The first submission of the branch run worked fine, but when the model resubmitted, it crashed with the follwing error:

-------------------------------------------------------------------------
 CESM BUILDNML SCRIPT STARTING
 - To prestage restarts, untar a restart.tar file into /glade/scratch/hannay/test001/run
 infile is /glade/scratch/hannay/test001/Buildconf/cplconf/cesm_namelist
CAM writing dry deposition namelist to drv_flds_in
CAM writing namelist to atm_in
CLM configure done.
CLM adding use_case 1850_control defaults for var sim_year with val 1850
CLM adding use_case 1850_control defaults for var sim_year_range with val constant
CLM adding use_case 1850_control defaults for var stream_year_first_ndep with val 1850
CLM adding use_case 1850_control defaults for var stream_year_last_ndep with val 1850
CLM adding use_case 1850_control defaults for var use_case_desc with val Conditions to simulate 1850 land-use
CICE configure done.
Getting init_ts_file_fmt from /glade/scratch/hannay/test001/run/rpointer.ocn.restart
POP2 build-namelist: ocn_grid is gx1v6
POP2 build-namelist: ocn_tracer_modules are  iage
ERROR: rtm.buildnml.csh failed
ERROR from preview namelist - EXITING
-------------------------------------------------------------------------

 

I am doing something very simple and here is the commands I used:

cd /glade/p/cesmdata/cseg/collections/cesm1_2_0/scripts
./create_newcase -case /glade/scratch/hannay/test001 -res ne30_g16 -compset B_1850_CAM5_CN -mach yellowstone
cd /glade/scratch/hannay/test001
./cesm_setup
./test001.build

mv /glade/scratch/hannay/test001 /glade/scratch/hannay/test001_initial
 cd /glade/p/cesmdata/cseg/collections/cesm1_2_0/scripts
./create_newcase -case /glade/scratch/hannay/test001 -res ne30_g16 -compset B_1850_CAM5_CN -mach yellowstone
cd /glade/scratch/hannay/test001
./xmlchange RUN_TYPE=branch,RUN_REFCASE=test001,RUN_REFDATE=0001-01-06,GET_REFCASE=FALSE,RESUBMIT=1,BRNCH_RETAIN_CASENAME=TRUE
mkdir /glade/scratch/hannay/test001/run/.
/bin/cp  /glade/scratch/hannay/archive/test001/rest/0001-01-06-00000/* /glade/scratch/hannay/test001/run/.
./cesm_setup
./test001.build

hannay

Using a recent version of rtm.buildnml.csh seems to solve the problem.

I replaced  Buildconf/rtm.buildnml.csh  with cesm1_3_beta04/models/rof/rtm/bld/rtm.buildnml.csh and it works fine.

So there is a bug in cesm1_2_0 but it is fixed in later versions of the model (for instance: cesm1_3_beta04).

Thanks to Jim for the tip.

aliceb

A similar issue is documented in the CESM1.2 Known Problems under River/RTM Bugzilla 1777.

http://www.cesm.ucar.edu/models/cesm1.2/tags/cesm1_2/knownproblems.html

Alice Bertini
Software Engineer
NCAR / CESM

Log in or register to post comments

Who's new

  • pv25@...
  • tangyanlia@...
  • hkleppin
  • nperlin@...
  • emmons