Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Automatic input data download failed

chl

Christian
New Member
Hi,

I'm trying to verify my installation with the default case: ./create_newcase --machine=homebrew --case mycase --compset X --res f19_g16. I managed to get the setup and build to pass. However, the automatic download of the input_data fails; a manual download works but its just very tedious. The problem sounds similar to scripts_regression_tests failing during port to new local system due to error during inputdata download · Issue #3087 · ESMCI/cime.

Attached the output of ./check_input_data --download --debug

Any ideas would be highly appreciated.

Thanks,
Christian
 

Attachments

  • log.txt
    7.1 KB · Views: 7

jedwards

CSEG and Liaisons
Staff member
With which protocol does manual download work? You can adjust the order that protocols are attempted by changing the order in config_inputdata.xml
 

chl

Christian
New Member
Hi,

Thanks for the quick reply.

I tried to change the order as suggested in the other thread. This didn't help. Manually, wget works (with the command string that is used in ./check_input_data), e.g.

lessig@einstein cesm-inputdata % wget --no-check-certificate --user anonymous --password user@example.edu ftp://ftp.cgd.ucar.edu/cesm/inputdata/cpl/gridmaps/gx1v6/map_gx1v6_TO_fv1.9x2.5_aave.130322.nc cpl/gridmaps/gx1v6


--2020-06-18 21:10:44-- ftp://ftp.cgd.ucar.edu/cesm/inputdata/cpl/gridmaps/gx1v6/map_gx1v6_TO_fv1.9x2.5_aave.130322.nc


=> ‘map_gx1v6_TO_fv1.9x2.5_aave.130322.nc’


Resolving ftp.cgd.ucar.edu (ftp.cgd.ucar.edu)... 128.117.23.220


Connecting to ftp.cgd.ucar.edu (ftp.cgd.ucar.edu)|128.117.23.220|:21... connected.


Logging in as anonymous ... Logged in!


==> SYST ... done. ==> PWD ... done.


==> TYPE I ... done. ==> CWD (1) /cesm/inputdata/cpl/gridmaps/gx1v6 ... done.


==> SIZE map_gx1v6_TO_fv1.9x2.5_aave.130322.nc ... 16245156


==> PASV ... done. ==> RETR map_gx1v6_TO_fv1.9x2.5_aave.130322.nc ... done.


Length: 16245156 (15M) (unauthoritative)





map_gx1v6_TO_fv1.9x 100%[===================>] 15,49M 552KB/s in 27s





2020-06-18 21:11:14 (578 KB/s) - ‘map_gx1v6_TO_fv1.9x2.5_aave.130322.nc’ saved [16245156]





--2020-06-18 21:11:14-- http://cpl/gridmaps/gx1v6


Resolving cpl (cpl)... failed: nodename nor servname provided, or not known.


wget: unable to resolve host address ‘cpl’


FINISHED --2020-06-18 21:11:14--


Total wall clock time: 30s


Downloaded: 1 files, 15M in 27s (578 KB/s)
 

chl

Christian
New Member
The problem apparently arose from having multiple servers in config_inputdata.xml. With only the ftp one in there it worked (I presume only svn or wget would work as well).

I was stepping through the code to locate the issue and it seems it arises from the merging of the checksum files in CESM/cime/scripts/lib/CIME/case/check_input_data.py:57-60 (on my Mac in any case).
 
Top