Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Does CLM5 compatible with FMOZ compset in CESM2.1.3?

Hemraj

Hemraj Bhattarai
New Member
Hi,
FMOZ by default is taking CAM4 and CLM4.5 (CESM2.2.0 Component Sets Definitions). I tried to change CLM4.5 to CLM5 using the code (./xmlchange CLM_CONFIG_OPTS="-phys clm5_0") in my case script, but it ended with some error message (ERROR : CLM build-namelist::CLMBuildNamelist::setup_logic_lnd_tuning() : First part of lnd_tuning_mode MUST match the CLM version you are using.).

I retried changing clm5_0 to clm4_5, keeping every other thing the same and the case script run well. Does it mean, CLM5 is not compatible with the FMOZ compset in CESM2.1.3?

I tried this in both BGC and SP mode, the error is same in both cases.

Thank you.

Best,
Hemraj
 

Hemraj

Hemraj Bhattarai
New Member
Let me make it easier to understand, FMOZ compset by default is "2000_CAM40%TMOZ_CLM45%SP_CICE%PRES_DOCN%DOM_RTM_SGLC_SWAV", can I change CLM45 to CLM50 like "2000_CAM40%TMOZ_CLM50%SP_CICE%PRES_DOCN%DOM_RTM_SGLC_SWAV". If yes, how? Simply changing the number doesn't work.
Thank you!!
 

oleson

Keith Oleson
CSEG and Liaisons
Staff member
The error you are getting in the first instance is due the fact that the case is setup out of the box with LND_TUNING_MODE=clm4_5_cam6.0 and you've changed the physics to -phys clm5_0, and so it is complaining that clm4_5 doesn't match clm5_0.
You should however be able to change CLM45 to CLM50 in the compset name in a new case.
I tried this with cesm2.1.3 and both cases (w/CLM45 and w/CLM50) ran fine. The LND_TUNING_MODE gets set properly if you do it that way.
 

Hemraj

Hemraj Bhattarai
New Member
Thank you @oleson. Yes, I can change that way as you mentioned.

One concern I have here is, although in the compset we specify CAM40 and CLM50, if we check "env_run.xml" we can still see CAM6 is being used ( <entry id="LND_TUNING_MODE" value="clm5_0_cam6.0">). I am a bit confused, whether our simulation is taking CAM4 or CAM6? This is because our compset is set to be CAM4 but LND_TUNING_MODE has CAM6.
Many thanks!
 

oleson

Keith Oleson
CSEG and Liaisons
Staff member
The case will be using cam4 as the atmospheric model. The cam6 in the LND_TUNING_MODE refers to a couple of land fire parameters that depend on whether clm4_5 or clm5 is used. They have been tuned for use with cam6. There is no LND_TUNING_MODE for cam4 (or cam5).
The FMOZ compset is listed as "defined", not scientifically supported. So you would need to verify yourself that the case is giving reasonable answers.
 
Top