Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

-res T62_g16 -compset G doesn't work?

Hi,I have successfully compiled and run '-res T62_g37 -compset G' in CESM1.1.1.However, when I used the same set of parameters/ configurations but different resolution ''-res T62_g16 -compset G', the model can be compiled without a warning but failed to excute. I checked the log files, in cpl.log:cpl.log.130516-131514(seq_mct_drv) : Initialize each component: atm, lnd, rof, ocn, ice, and glc(seq_mct_drv) : Initialize atm component ATM(seq_mct_drv) : Initialize lnd component LND(seq_mct_drv) : Initialize rof component ROF(seq_mct_drv) : Initialize ocn component OCN(seq_mct_drv) : Initialize ice component ICE(shr_sys_abort) ERROR: restformat: number of records on restart file not supported(shr_sys_abort) WARNING: calling shr_mpi_abort() and stoppingWhat's the meaning of "number of records on restart file not supported"? How to fix it? What's the possible problem? Thanks!------------------------------------------Also I listed the error messages in ccsm.log file:ccsm.log.130516-131514CalcWorkPerBlock: Total blocks:   256 Ice blocks:    82 IceFree blocks:   160 Land blocks:    14[compute-0-6:11271] *** Process received signal ***[compute-0-6:11271] Signal: Segmentation fault (11)[compute-0-6:11271] Signal code: Address not mapped (1)[compute-0-6:11271] Failing at address: (nil)[compute-0-6:11271] [ 0] /lib64/libpthread.so.0 [0x38bf80e7c0][compute-0-6:11271] [ 1] /share/apps/openmpi/1.4.3-gcc-4.6.1/lib/libmpi_f77.so.0(MPI_ABORT+0x1b) [0x2affd2dd12ab][compute-0-6:11271] [ 2] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__shr_mpi_mod_MOD_shr_mpi_abort+0xd1) [0x87eaf1][compute-0-6:11271] [ 3] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__shr_sys_mod_MOD_shr_sys_abort+0x210) [0x8beb66][compute-0-6:11271] [ 4] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__ice_exit_MOD_abort_ice+0x10) [0x50a060][compute-0-6:11271] [ 5] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__ice_restart_MOD_restformat+0x168) [0x54997c][compute-0-6:11271] [ 6] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__ice_restart_MOD_restartfile_bin+0x57c) [0x54fa3a][compute-0-6:11271] [ 7] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__cice_initmod_MOD_cice_init+0x165) [0x588605][compute-0-6:11271] [ 8] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__ice_comp_mct_MOD_ice_init_mct+0x21a6) [0x4f2ff0][compute-0-6:11271] [ 9] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(__ccsm_comp_mod_MOD_ccsm_init+0x80ba) [0x485e72][compute-0-6:11271] [10] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe(main+0x4a) [0x49518a][compute-0-6:11271] [11] /lib64/libc.so.6(__libc_start_main+0xf4) [0x38bec1d994][compute-0-6:11271] [12] /home/xin.miao/CESM/cesm1_1_1/scripts/testG16/EXE/cesm.exe [0x470799][compute-0-6:11271] *** End of error message ***--------------------------------------------------------------------------mpirun noticed that process rank 0 with PID 11271 on node compute-0-6.local exited on signal 11 (Segmentation fault).--------------------------------------------------------------------------  
 

dbailey

CSEG and Liaisons
Staff member
This should really go in the CICE modeling section. This means you are trying to read an initial/restart file in the ice that is not supported. What type of run is this? Initial/hybrid/branch .. etc? What is ice_ic set to in your ice_in file?
 

dbailey

CSEG and Liaisons
Staff member
This should really go in the CICE modeling section. This means you are trying to read an initial/restart file in the ice that is not supported. What type of run is this? Initial/hybrid/branch .. etc? What is ice_ic set to in your ice_in file?
 
Hi, dbailey,I confirm that it is an initial run: in env_run.xml --     This is the default setting, I didn't change it.In ice_in file, ice_ic = '/home/xin.miao/CESM/inputdata/ice/cice/iced.0001-01-01.gx1v6_20080212'This file was manually downloaded, because the previous '-res T62_g37 -compset G' version can't download it automatically, -- please refer to
http://bb.cgd.ucar.edu/weird-problem-compset-h-running
So I guess I need another ice_in restart file after I changed the resolution? It did not give me any warning when compiling.
BTW, what's the function of 'iced.0001-01-01.gx1v6_20080212' anyway? Why do I need it for restarting?Thanks, Shane
 
Hi, dbailey,I confirm that it is an initial run: in env_run.xml --     This is the default setting, I didn't change it.In ice_in file, ice_ic = '/home/xin.miao/CESM/inputdata/ice/cice/iced.0001-01-01.gx1v6_20080212'This file was manually downloaded, because the previous '-res T62_g37 -compset G' version can't download it automatically, -- please refer to
http://bb.cgd.ucar.edu/weird-problem-compset-h-running
So I guess I need another ice_in restart file after I changed the resolution? It did not give me any warning when compiling.
BTW, what's the function of 'iced.0001-01-01.gx1v6_20080212' anyway? Why do I need it for restarting?Thanks, Shane
 

dbailey

CSEG and Liaisons
Staff member
Hi Shane,The CICE needs an initial or restart file to start the state from just as any of the components do. I noticed that your ice_ic is pointing to a gx1v6 restart, but your resolution is T62_g37, i.e. the ocean and ice are on the gx3v7 or nominal 3-degree grid. You must have changed the ice_ic namelist value? Try setting up a new case and see what restart file it points you to. Then you'll need to manually download that one. I have a feeling something was lost in the previous communication and you inadvertently downloaded the gx1v6 restart.Dave
 

dbailey

CSEG and Liaisons
Staff member
Hi Shane,The CICE needs an initial or restart file to start the state from just as any of the components do. I noticed that your ice_ic is pointing to a gx1v6 restart, but your resolution is T62_g37, i.e. the ocean and ice are on the gx3v7 or nominal 3-degree grid. You must have changed the ice_ic namelist value? Try setting up a new case and see what restart file it points you to. Then you'll need to manually download that one. I have a feeling something was lost in the previous communication and you inadvertently downloaded the gx1v6 restart.Dave
 
Hi, Xinmiao:
I am struggling on installing CESM1.1.1 on my machine. Can I ask which compiler you used for installing CESM1.1.1, intel or PGI? I am using PGI and got problems with that. thanks,
 
Hi, Xinmiao:
I am struggling on installing CESM1.1.1 on my machine. Can I ask which compiler you used for installing CESM1.1.1, intel or PGI? I am using PGI and got problems with that. thanks,
 
Dave, thanks for your hint, I figure it out -- yes, it is still the ice_in file problem. Last time in T62_g37 case, the model failed to download iced.0001-01-01.gx3v7_20080212 and give me a warning. This time when I tried T62_g16,it seems successfully download 'iced.0001-01-01.gx1v6_20080212' file but for some reasons, the file size is 0! And there's no warning! After manually download the corresponding initial ice file, the problem solved.
I deeply appreciate your quick response! Shane
 
Dave, thanks for your hint, I figure it out -- yes, it is still the ice_in file problem. Last time in T62_g37 case, the model failed to download iced.0001-01-01.gx3v7_20080212 and give me a warning. This time when I tried T62_g16,it seems successfully download 'iced.0001-01-01.gx1v6_20080212' file but for some reasons, the file size is 0! And there's no warning! After manually download the corresponding initial ice file, the problem solved.
I deeply appreciate your quick response! Shane
 
Hi, Xin MiaoThanks for your providing help. The online user manual looks better than the pdf one.

I compiled CESM1.1.1 on our linux cluster and got a series of problems seemingly related to the compiler or path configuration. So I am wondering which compiler you are using and if possible its version.

thanks in advance for telling me that and please don't forget to send me your script at ljdiao@gmail.com

 
Hi, Xin MiaoThanks for your providing help. The online user manual looks better than the pdf one.

I compiled CESM1.1.1 on our linux cluster and got a series of problems seemingly related to the compiler or path configuration. So I am wondering which compiler you are using and if possible its version.

thanks in advance for telling me that and please don't forget to send me your script at ljdiao@gmail.com

 
For the initial problem (regarding CICE input files), see this post for a potential solution:https://bb.cgd.ucar.edu/port-validation-runtime-failure-error-restformat-number-records-restart-file-not-supported
 
For the initial problem (regarding CICE input files), see this post for a potential solution:https://bb.cgd.ucar.edu/port-validation-runtime-failure-error-restformat-number-records-restart-file-not-supported
 
Top