Main menu

Navigation

COLDSST: encountered in cldfrc

3 posts / 0 new
Last post
rangel@...
COLDSST: encountered in cldfrc

Dear users,

 

I'm running CAM5 standalone, and I'm facing a problem that I do not know how to solve.

 

First, I'm interpolating CFS data to CAM's grid, overwriting some variables of the initial file (cami-mam3_0000-01-01_1.9x2.5_L30_c090306.nc) and also the sst file (sst_HadOIBl_bc_1.9x2.5_clim_c061031.nc).

 

Then, I configure and point the CAM build-namelist to those files:

 

 ../../configure -v -fc gfortran -dyn fv -hgrid 1.9x2.5 -nospmd -nosmp -debug -test

 

../../build-namelist -test -v -config /home/clima/CESM/cesm1_2_1/models/atm/cam/bld/10rodada_membros/m1/config_cache.xml -namelist "&atm ncdata='/home/clima/CESM/cesm1_2_1/models/atm/cam/bld/10rodada_membros/m1/cami_1.9x2.5_L30_c20180505.nc' start_ymd=101 stop_option='nmonths' stop_n=3  bndtvs='/home/clima/CESM/cesm1_2_1/models/atm/cam/bld/10rodada_membros/m1/sst_HadOIBl_bc_1.9x2.5_clim_c20180505.nc' /"

./cam >& cam.out

 

The output "log" file shows this message several times:

COLDSST: encountered in cldfrc:         121           5  0.12830816980450577        258.95364400148389

 COLDSST: encountered in cldfrc:         122           5  0.21456958848813840        258.66823598146436

 

The final lines of cam.out:

 *** halting in modal_aero_lw after nerr_dopaer =        1000

(shr_sys_abort) WARNING: calling shr_mpi_abort() and stopping

MPI_Abort: error code = 1001

MCT::m_Router::initp_: RGSMap indices not increasing...Will correct

MCT::m_Router::initp_: GSMap indices not increasing...Will correct

MCT::m_Router::initp_: GSMap indices not increasing...Will correct

MCT::m_Router::initp_: RGSMap indices not increasing...Will correct

MCT::m_Router::initp_: RGSMap indices not increasing...Will correct

MCT::m_Router::initp_: GSMap indices not increasing...Will correct

MCT::m_Router::initp_: GSMap indices not increasing...Will correct

MCT::m_Router::initp_: RGSMap indices not increasing...Will correct

MCT::m_Router::initp_: RGSMap indices not increasing...Will correct

MCT::m_Router::initp_: GSMap indices not increasing...Will correct

 

 

And then the model stops.

 

What could be happening?

I looked for the "COLDSST" message here in the forum and found one post, but without answers. (https://bb.cgd.ucar.edu/node/1001366)

 

 

Any help will be appreciated.

eaton

The error is coming from this code in models/atm/cam/src/physics/cam/cloud_fraction.F90

 

    ierror = 0
    do i=1,ncol
       ! Adjust thetas(i) in the presence of non-zero ocean heights.
       ! This reduces the temperature for positive heights according to a standard lapse rate.
       if(ocnfrac(i).gt.0.01_r8) thetas(i)  = &
            ( sst(i) - lapse * phis(i) / gravit) * (pnot/ps(i))**cappa
       if(ocnfrac(i).gt.0.01_r8.and.sst(i).lt.260._r8) ierror = i
       clc(i) = 0.0_r8
    end do
    coef1 = gravit*864.0_r8    ! conversion to millibars/day

    if (ierror > 0) then
       write(iulog,*) 'COLDSST: encountered in cldfrc:', lchnk,ierror,ocnfrac(ierror),sst(ierror)
    endif


My guess is that it's related to changes to the SST dataset.

rangel@...

Hi Eaton.

Perhaps I made a mistake when interpolating the sst field. I'll check this now.

Thanks!

Log in or register to post comments

Who's new

  • liaogh@...
  • liquanxin2014@...
  • marro.michele89@...
  • sowon@...
  • kiranjadhav1209@...