Main menu

Navigation

errors while submitting run script on linux cluster

2 posts / 0 new
Last post
cathryn.meyer@...
errors while submitting run script on linux cluster

Hello,

I am attempting to get CCSM3.0 up and running on a linux intel xeon GBEthernet cluster. I have successfully built the model, and am now submitting the script $CASE.generic_linux.run, however I get the following output:

------------------------------------------------------------------------
/var/spool/PBS/mom_priv/jobs/12332.stora.SC: line 24: setenv: command not found
/var/spool/PBS/mom_priv/jobs/12332.stora.SC: line 50: syntax error near unexpected token `('
/var/spool/PBS/mom_priv/jobs/12332.stora.SC: line 50: `foreach n (1 2 3 4 5)'
------------------------------------------------------------------------

In the beginning of the run script, I have the line #! /bin/tcsh, so I am not sure why the setenv command is not recognized. I get the same error regardless of the shell I'm in or the syntax I use. Also, I am not sure if there is an error in the "foreach" line, or if that is the correct syntax to use. Does anybody have any ideas?

Thanks,
Cathy

cathryn.meyer@...

I seem to be having issues compiling the code $CASE.generic_linux.run. I am using mpich version 1.2.5-ch_p4 on a linux cluster described in the post above. Has anybody had to make code changes to the run script to get it to work? I get several syntax errors (more than the ones shown above) and I'm not sure how to fix them correctly. Any help in this matter would be most appreciated.

Thanks,
Cathy

Log in or register to post comments

Who's new

  • opioronald123@...
  • shimura.tomoya....
  • rack.hun.son@...
  • nathalie.schall...
  • sf870222@...