Main menu

Navigation

Porting CESM 1.2.0 to Gordon@SDSC and Vesta@ANL

6 posts / 0 new
Last post
hellyj@...
Porting CESM 1.2.0 to Gordon@SDSC and Vesta@ANL

Hi Jim.

I'm most of the way along in porting CESM 1.2.0 to Gordon at SDSC and am trying to run ERS.f19_g16.X.gordon_intel.t01.test via ERS.f19_g16.X.gordon_intel.t01.submit.  Gordon uses qsub.  The job seems to submit ok but the output is confusing and I'm a bit stuck trying to figure out what's wrong.  Seems like the environment's not right but I don't know what to expect and can't figure out where 'templar' is so can't debug the *.submit script very effectively.

Also, when I look at the *.run script (for some insight), I notice that the test about 'cesm.log' seems to actually be 'ccsm.log'.  I don't know if this is a bug or I'm misunderstanding something.

Any pointers as to what might be wrong are most welcome.

Thanks.

J.

=========================================== standard out ===========================

ERS.f19_g16.X.gordon_intel.t01.test.o772390

-------------------------------------------------------------------------
CESM BUILDNML SCRIPT STARTING
- To prestage restarts, untar a restart.tar file into /oasis/scratch/hellyj/spcam_testcase/hellyj/ERS.f19_g16.X.gordon_intel.t01/run
infile is /home/hellyj/src/cesm1_2_0/scripts/ERS.f19_g16.X.gordon_intel.t01/Buildconf/cplconf/cesm_namelist
CESM BUILDNML SCRIPT HAS FINISHED SUCCESSFULLY
-------------------------------------------------------------------------
-------------------------------------------------------------------------
CESM PRESTAGE SCRIPT STARTING
- Case input data directory, DIN_LOC_ROOT, is /oasis/scratch/hellyj/spcam_testcase/inputdata
- Checking the existence of input datasets in DIN_LOC_ROOT
CESM PRESTAGE SCRIPT HAS FINISHED SUCCESSFULLY
-------------------------------------------------------------------------
Mon Jun 17 20:41:01 PDT 2013 -- CSM EXECUTION BEGINS HERE
Mon Jun 17 20:41:11 PDT 2013 -- CSM EXECUTION HAS FINISHED
Model did not complete - no cesm.log file present - exiting
Nodes: gcn-13-51

=========================================== error output ===========================

ERS.f19_g16.X.gordon_intel.t01.test.e772390

ls: No match.
gunzip: No match.
ls: No match.
ls: No match.
mv: missing destination file operand after `.base'
Try `mv --help' for more information.
if: Missing file name.

hellyj@...

So, I found this in another *.submit log.  From earlier responses you said this was due to submission from the command-line but that's not the case here since this was put in via *.submit.  Must be something wrong with the batch submission?

 

[hellyj@gordon-ln2 ERS.f19_g16.X.gordon_intel.t01]$ more /oasis/scratch/hellyj/spcam_testcase/hellyj/ERS.f19_g16.X.gordon_intel.t01/run/ccsm.log.130618-092708

mpirun.lsf: Command not found.

 
hellyj@...

I may have found a path to debugging.  Seems like the mkbatch file is wrong.

hellyj@...

So.  I corrected the mkbatch file so no more errors from the batch submission but I still can't get past this...

===========================================

Warning: no access to tty (Bad file descriptor).

Thus no job control in this shell.

-------------------------------------------------------------------------

 CESM BUILDNML SCRIPT STARTING

 - To prestage restarts, untar a restart.tar file into /oasis/scratch/hellyj/spcam_testcase/hellyj/ERS.f19_g16.X.gordon_intel.t01/run

 infile is /home/hellyj/src/cesm1_2_0/scripts/ERS.f19_g16.X.gordon_intel.t01/Buildconf/cplconf/cesm_namelist

 CESM BUILDNML SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

-------------------------------------------------------------------------

 CESM PRESTAGE SCRIPT STARTING

 - Case input data directory, DIN_LOC_ROOT, is /oasis/scratch/hellyj/spcam_testcase/inputdata

 - Checking the existence of input datasets in DIN_LOC_ROOT

 CESM PRESTAGE SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

Tue Jun 18 09:54:58 PDT 2013 -- CSM EXECUTION BEGINS HERE

Tue Jun 18 09:54:58 PDT 2013 -- CSM EXECUTION HAS FINISHED

ls: No match.

Model did not complete - no cesm.log file present - exiting

gunzip: No match.

ls: No match.

ls: No match.

mv: missing destination file operand after `.base'

Try `mv --help' for more information.

if: Missing file name.

Nodes:        gcn-5-74 gcn-5-76

 
jedwards

The fact that there is no cesm log present makes me think that you should try a very simple program like this one from the cesm users manual if you cannot run it successfully please talk with your system administration staff.

CESM Software Engineer

jedwards

After rereading your message - is there a ccsm.log file?   If so what is in it?   In the mkbatch.system script change ccsm.log to cesm.log.  

CESM Software Engineer

Log in or register to post comments

Who's new

  • jwolff
  • tinna.gunnarsdo...
  • sarthak2235@...
  • eolivares@...
  • shubham.gandhi@...