Main menu

Navigation

ERROR in mksurfdata_map when building single point model in CLM45

3 posts / 0 new
Last post
zichongchen22@...
ERROR in mksurfdata_map when building single point model in CLM45

Hi All,
     I am running single-point model of CLM4.5 and using mksurfdata.pl to create surface dataset.  When I run the command "./mksurfdata.pl -r usrspec -usr_gname 1x1_Marcell -usr_gdate 150925", I  could create several files successfully,but also got a error message as follow:
CSMDATA is /panfs/roc/groups/8/grifbake/public/inputdata/CESM 
resolution: 1x1_Marcell rcp=-999.9 sim_year = 1850
namelist: namelist
.............................
Attempting to make PFTs .....
 Creating surface datasets with the standard # of PFTs =          16
 domain_read_dims_2d read lon and lat dims from lon/lat
 domain_read initialized domain
 domain_read read LANDMASK
 Open PFT file: 
 /panfs/roc/groups/8/grifbake/public/inputdata/CESM/lnd/clm2/rawdata/pftlandused
 yn.0.5x0.5.simyr1850-2005.c090630/mksrf_landuse_rc1850_c090630.nc
(gridmap_map_read) reading mapping matrix data...
(gridmap_map_read) * file name                  : ../../shared/mkmapdata/map_0.5x0.5_MODIS_to_1x1_Marcell_nomask_aave_da_c150925.nc
 * matrix dimensions rows x cols :      259200  x           1
 * number of non-zero elements:            4
 domain_clean: cleaning       259200
 Successfully made PFTs
........................................
urface data output file = surfdata_1x1_Marcell_simyr1850_c150930.nc
    This file contains the land model surface data
 Diagnostic log file      = surfdata_1x1_Marcell_simyr1850_c150930.log
    See this file for a summary of the dataset
 
 Successfully created surface dataset
..................................
Attempting to make PFTs .....
 Creating surface datasets with the standard # of PFTs =          16
 netcdf error from domain_read rcode =            2  error = 
 No such file or directory                                                      
  
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image              PC                Routine            Line        Source             
mksurfdata_map     0000000000537FD1  Unknown               Unknown  Unknown
mksurfdata_map     0000000000536727  Unknown               Unknown  Unknown
mksurfdata_map     00000000004EE394  Unknown               Unknown  Unknown
mksurfdata_map     00000000004EE1A6  Unknown               Unknown  Unknown
mksurfdata_map     0000000000491364  Unknown               Unknown  Unknown
mksurfdata_map     00000000004960DD  Unknown               Unknown  Unknown
libpthread.so.0    00002AAFF5F89710  Unknown               Unknown  Unknown
mksurfdata_map     000000000053EE62  Unknown               Unknown  Unknown
mksurfdata_map     0000000000485320  Unknown               Unknown  Unknown
mksurfdata_map     000000000040D73D  mkdomainmod_mp_ch         788  mkdomainMod.F90
mksurfdata_map     000000000040D8DE  mkdomainmod_mp_do         396  mkdomainMod.F90
mksurfdata_map     000000000043921D  mkpftmod_mp_mkpft         233  mkpftMod.F90
mksurfdata_map     000000000045217B  MAIN__                    501  mksurfdat.F90
mksurfdata_map     000000000040A25E  Unknown               Unknown  Unknown
libc.so.6          00002AAFF61B5D5D  Unknown               Unknown  Unknown
mksurfdata_map     000000000040A0F9  Unknown               Unknown  Unknown
ERROR in mksurfdata_map: 44544

    I checked the namelist and  ensure the files fine. At the first time, The PFTs can be successfully created but the follow process showed that " netcdf error from domain_read rcode =2  error =No such file or directory".  I don't know why the information said netcdf error from domain_read at the second making PFTs. I think it might be my netcdf version incorrect, but I got the same output by using different netcdf versions such as fortran-4.4-intel-sp1-update3-parallel,fortran-4.2.intel,4.3.2-intel-sp1-update3-parallel, and so on. 
    I  attach the whole message and will appreciate any help you give me.

Attachment: 
spamiad@...

Hi,

I am receiving the same error creating surfdatasets for a global grid. Did you ever solve this issue?

sml122601@...

I am receiving the same error creating dynamic surfdatasets for a global grid. Did you ever solve this issue? Thank you very much!

Log in or register to post comments

Who's new

  • afroberts@...
  • richard.allard@...
  • tracy@...
  • 498749303@...
  • lijundesio@...