Main menu

Navigation

error while running slab ocean model with E_1850_C5CN: restformat:

2 posts / 0 new
Last post
11438023@...
error while running slab ocean model with E_1850_C5CN: restformat:

Hi,

I'm trying to run some experiment on our cluster, but found some problems I cannot fix.

My compset is E_1850_C5CN with a slab ocean, resolution is f19_g16, 

For the first step, I download the SOM forcing file "pop_frc.b.c40.B1850CN.f19_g16.100105.nc "  from "https://svn-ccsm-inputdata.cgd.ucar.edu/trunk/inputdata/ocn/docn7/SOM/" , and put it under **/inputdata/ocn/docn7/SOM

my sets include: 

DEBUG=TRUE; DOUT_S=TRUE; CLM_CONFIG_OPTS="-spinup AD" -append; CLM_FORCE_COLDSTART=on; 

and change DOCN_SOM_FILENAME=pop_frc.b.c40.B1850CN.f19_g16.100105.nc ;

Then i submit the run and it stops while running, the cesm.log file shows mistake as below:

 

------------------------------------------------------------------

  numro=         4673

 Opened existing file

 /public/home/longcao/CESM/inputdata/rof/rtm/initdata/rtmi.I1850CRUCLM45BGC.0241

 -01-01.R05_simyr1850_c130515.nc     1572864

 Reading setup_nml

 Reading grid_nml

 Reading ice_nml

 Reading tracer_nml

CalcWorkPerBlock: Total blocks:   384 Ice blocks:   126 IceFree blocks:   229 Land blocks:    29

--------------------------------------------------------------------------

MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD

with errorcode 1001.

 

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.

You may or may not see output from other processes, depending on

exactly when Open MPI kills them.

--------------------------------------------------------------------------

(shr_sys_abort) ERROR: restformat: number of records on restart file not supported

(shr_sys_abort) WARNING: calling shr_mpi_abort() and stopping

forrtl: error (78): process killed (SIGTERM)

-------------------------------------------------------------------------------------

 

and I look into each component's log file finging the problem mostly occurs in the ocean part.

 

--------------------------

(shr_strdata_print)

(shr_strdata_print) nvectors    =      0

(shr_strdata_print) ----------------------------------------------------------

(docn_comp_init)  initialize gsmaps

(docn_comp_init) copy domains

(docn_comp_init) allocate AVs

(shr_dmodel_readLBUB) reading file: /public/home/longcao/CESM/inputdata/ocn/docn7/SOM/pop_frc.b.c40.B1850CN.f19_g16.100105.nc      12

(shr_dmodel_readLBUB) reading file: /public/home/longcao/CESM/inputdata/ocn/docn7/SOM/pop_frc.b.c40.B1850CN.f19_g16.100105.nc       1

(docn_comp_run) ocn: model date    10101       0s

(docn_comp_init) docn_comp_init done

----------------------------------------------

 

 

So is this error occur because I use the wrong SOM forcing file ? Or for some other reasons ? 

BTW, I can run B1850CN compset correctly.

 

Thanks!

 

11438023@...

And If it is because the forcing file, can I use the B1850C5CN.f09_g16 file for my case? since my resolution is f19_g16

Log in or register to post comments

Who's new

  • praveenmaniyatt@...
  • arjunbabun11@...
  • lama@...
  • sisi393@...
  • 1658093099@...