Main menu

Navigation

the errors of cesm.exe building

4 posts / 0 new
Last post
shanru@...
the errors of cesm.exe building

mpifort  -o /global/homes/s/shanru/research/CESMEXPR/test3cori/bld/cesm.exe ccsm_comp_mod.o ccsm_driver.o mrg_mod.o seq_avdata_mod.o seq_diag_mct.o seq_domain_mct.o seq_flux_mct.o seq_frac_mct.o seq_hist_mod.o seq_map_esmf.o seq_map_mod.o seq_mctext_mod.o seq_rest_mod.o  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -latm  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -lice  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -llnd  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -locn  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -lrof  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -lglc  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib/ -lwav -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/lib -lcsm_share  -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/mct/mct -lmct -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/mct/mpeu -lmpeu -L/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/pio -lpio -lgptl -L/opt/cray/pe/netcdf/4.4.1.1.3/intel/16.0/lib -lnetcdf -lnetcdff

/usr/bin/ld: cannot find -lugni

/usr/bin/ld: cannot find -lxpmem

/usr/bin/ld: cannot find -ludreg

/usr/bin/ld: cannot find -lalpslli

/usr/bin/ld: cannot find -lalpsutil

/usr/bin/ld: cannot find -lwlm_detect

/global/homes/s/shanru/research/CESMEXPR/test3cori/Tools/Makefile:687: recipe for target '/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/cesm.exe' failed

gmake: *** [/global/homes/s/shanru/research/CESMEXPR/test3cori/bld/cesm.exe] Error 1


Anyone has any idea?

jedwards

It looks like maybe you are on a cray system and didn't load the correct modules.   But since you didn't tell me anything about what system you are trying to use or what version of cesm you are trying to build all I can do is make a guess. 

CESM Software Engineer

shanru@...

cesm1_2_1

compiler: intel 

MPILIB: openmpi/2.0.3

 

shanru@...

when i use the "mpi-serial", it can be built successfully. 

but does  the parallel compiler not work well?

 

Log in or register to post comments

Who's new

  • ezhu@...
  • 1260680980@...
  • 675881908@...
  • liruichao@...
  • krc139@...