Main menu

Navigation

Issue attempting to create set 1 with the lnd_diag4.2.28 package

3 posts / 0 new
Last post
taylor.hughlett@...
Issue attempting to create set 1 with the lnd_diag4.2.28 package

Hello,

I am attempting to use the land diagnostic package lnd_diag4.2.28 to create some plots, and I have come across a list of errors that I am unable to find the source of. I've grepped every available file with the variables the error is pertaining to with no luck. Any help would be excellent!

Here is the error I am getting:

(0)     screening case 1 :  TOTPFTC

(0)     screening case 1 :  TOTPFTN

(0)     screening case 1 :  TOTPRODC

(0)     screening case 1 :  TOTPRODN

(0)     screening case 1 :  TOTSOMC

(0)     screening case 1 :  TOTSOMN

(0)     screening case 1 :  TOTVEGC

(0)     screening case 1 :  TOTVEGN

(0)     screening case 1 :  TREFMNAV

(0)     screening case 1 :  TREFMNAV_R

(0)     screening case 1 :  TREFMNAV_U

(0)     screening case 1 :  TREFMXAV

(0)     screening case 1 :  TREFMXAV_R

(0)     screening case 1 :  TREFMXAV_U

(0)     screening case 1 :  TSA

(0)     screening case 1 :  TSAI

(0)     screening case 1 :  TSA_R

(0)     screening case 1 :  TSA_U

(0)     screening case 1 :  TSOI

(0)     screening case 1 :  TSOI_10CM

(0)     screening case 1 :  TSOI_ICE

(0)     screening case 1 :  TV

(0)     screening case 1 :  U10

(0)     screening case 1 :  URBAN_AC

(0)     screening case 1 :  URBAN_HEAT

(0)     screening case 1 :  WA

(0)     screening case 1 :  WASTEHEAT

(0)     screening case 1 :  WIND

(0)     screening case 1 :  WOODC

(0)     screening case 1 :  WOODC_ALLOC

(0)     screening case 1 :  WOODC_LOSS

(0)     screening case 1 :  WOOD_HARVESTC

(0)     screening case 1 :  WOOD_HARVESTN

(0)     screening case 1 :  WT

(0)     screening case 1 :  XSMRPOOL

(0)     screening case 1 :  XSMRPOOL_RECOVER

(0)     screening case 1 :  ZBOT

(0)     screening case 1 :  ZWT

(0)     Leaving lnd_NaNScreen

Starting set1 ----------------------------------------

 Copyright (C) 1995-2015 - All Rights Reserved

 University Corporation for Atmospheric Research

 NCAR Command Language Version 6.3.0

 The use of this software is governed by a License Agreement.

 See http://www.ncl.ucar.edu/ for more details.

(0)     =========================================

(0)     Starting:  set_1.ncl

(0)     Start Time: Thu Nov 17 13:15:27 MST 2016

(0)     =========================================

(0)     Truncating soil levels to 10 levels [caseid: b.e12.B1850CN.PETM8x.f09_g16  nlev:  15]

(0)      TSA

fatal:CheckArray:Each vector in the caXArray array must have at least 2 elements

fatal:CoordArraysInitialize:caXArray resource is invalid

fatal:Unable to initialize layer-Can't Create

fatal:Unable to access object with id:-4

fatal:PID #-4 can't be found in NhlSetValues

fatal:Unable to access object with id:-4

warning:Unable to add DataItem "(null)" to DataList "xyCoordData"

fatal:CompileDataList:DataList has no valid members

fatal:Unable to access object with id:-4

warning:Unable to add DataItem "(null)" to DataList "xyCoordData"

fatal:CompileDataList:DataList has no valid members

fatal:Argument type mismatch on argument (0) of (attsetvalues_check) can not coerce

fatal:["Execute.c":8575]:Execute: Error occurred at or near line 12478 in file $NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_code.ncl

fatal:["Execute.c":8575]:Execute: Error occurred at or near line 5083 in file $NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_csm.ncl

fatal:["Execute.c":8575]:Execute: Error occurred at or near line 209 in file /glade/u/home/hughlett/lnd_diag4.2.28/code/model-obs/set_1.ncl 

Premature Exit (set1)

 

 

EXIT lnd_diag-version:/glade/u/home/hughlett/lnd_diag4.2.28 Thu Nov 17 13:15:27 MST 2016


As I mentioned earlier, I've not been able to find "xyCoordData", "caXArray" or "attsetvalues_check", so I am at a loss with how to proceed.

Thanks in advance for your time and help!

Taylor M. Hughlett, Ph.D.
Postdoctoral Research Fellow
Department of Earth & Environmental Sciences
University of Texas at Arlington

oleson

This error (fatal:CheckArray:Each vector in the caXArray array must have at least 2 elements) indicates that possibly you have set the trends to be only one year?  I see you are running on yellowstone, if you still have problems, we can take this offline and I can hopefully get you running (oleson@ucar.edu).

 

Keith

taylor.hughlett@...

Thank you so much! That helped me fix the problem! I turned off all of the trends and now it is running without issue.

Taylor M. Hughlett, Ph.D.
Postdoctoral Research Fellow
Department of Earth & Environmental Sciences
University of Texas at Arlington

Log in or register to post comments

Who's new

  • 935881015@...
  • zwolff@...
  • daigk@...
  • kimberly.a.casey@...
  • qin-y14@...