Main menu

Navigation

MPI-ERROR

1 post / 0 new
shivaprazad19@...
MPI-ERROR

Hi all,

 

Can anyone please help me to figure out the  following error while I configured CICE standalone model. I have given the inputs in NetCDF format.

 

 ice_open_nc: Cannot open /home/sprasad/Work/CICE-v5.0/input-2009/q_10.2009.nc
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0

===================================================================================
=   BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
=   EXIT CODE: 1
=   CLEANING UP REMAINING PROCESSES
=   YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
===================================================================================

The input file format is as follows

netcdf q_10.2009 {
dimensions:
    ni = 140 ;
    nj = 250 ;
    time = UNLIMITED ; // (1459 currently)
variables:
    float ni(ni) ;
        ni:units = " " ;
        ni:point_spacing = "even" ;
        ni:axis = "X" ;
    float nj(nj) ;
        nj:units = " " ;
        nj:point_spacing = "even" ;
        nj:axis = "Y" ;
    double time(time) ;
        time:units = "seconds since 2009-01-01 00:00:00" ;
        time:long_name = "Time" ;
        time:axis = "T" ;
        time:calendar = "gregorian" ;
        time:standard_name = "time" ;
    float q_10(time, nj, ni) ;
        q_10:missing_value = -32767.f ;
        q_10:_FillValue = -32767.f ;
        q_10:long_name = "Specific Humidity" ;
        q_10:units = "Kg/Kg" ;
        q_10:history = "From model-2009/q_10.2009.nc"

and I have made the following change in the ice_forcing.f90 to read the NetCDF data format

       recslot = 2
       ixp = -99     

        fieldname='q_10'
        call read_data_nc (read6, 0, fyear, ixm, ixx, ixp, &
                            maxrec, humid_file,fieldname,Qa_data, &
                            field_loc_center, field_type_scalar)

 

Thanks and Regards

Siva

Who's new

  • Nicholas.Davis@...
  • numarsanifa@...
  • bingdian_46@...
  • mxy2832029@...
  • nthg2000@...