Main menu

Navigation

NETCDF not enabled in the build.... FindNETCDF Patch not suitable for my setup? CESM 1.2.2

3 posts / 0 new
Last post
leanne.wake@...
NETCDF not enabled in the build.... FindNETCDF Patch not suitable for my setup? CESM 1.2.2

Hi -

Hope you dont mind me starting a new topic. Having supposedly built CESM correctly through to batch script and sent a job I get the following errors back.

"NETCDF not enabled". Having dug further, I find the following in the final 20 lines of CESM.log:

dead_setNewGrid decomp 2d           15         184          69          72           1          46

 pio_support::pio_die:: myrank=          -1 : ERROR: nf_mod.F90:        1229 : NETCDF not enabled in the build

 pio_support::pio_die:: myrank=          -1 : ERROR: nf_mod.F90:        1229 : NETCDF not enabled in the build

 pio_support::pio_die:: myrank=          -1 : ERROR: nf_mod.F90:        1229 : NETCDF not enabled in the build

 pio_support::pio_die:: myrank=          -1 : ERROR: nf_mod.F90:        1229 : NETCDF not enabled in the build

--------------------------------------------------------------------------

MPI_ABORT was invoked on rank 9 in communicator MPI_COMM_WORLD with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes. You may or may not see output from other processes, depending on exactly when Open MPI kills them.

So, having checked earlier posts, I went to the pio build log and sure enough I found:
NETCDF built without MPIIO-- Could NOT find HDF5 (missing:  HDF5_INCLUDE_DIRS)-- Could NOT find NETCDF (missing:  NETCDF_LIBRARIES NETCDF_C_LIBRARY NETCDF_INCLUDE_DIR)-- Found pnetcdf: /cm/shared/oswald-apps/pnetcdf/intel/1.7.0/lib/libpnetcdf.a-- MPIIO detected and enabled.-- MPI Fortran module detected and enabled.-- Configuring done-- Generating done I though the FindNETCDF.cmake patch described in another thread may have helped, but it doesnt seem so here. Maybe the patch was system specific.  Is it a good idea to set the missing parameters manually using setenv, or something similar? Thanks in advance, Leanne 
jedwards

Yes try setting NETCDF_PATH in your enviroment and rebuild pio.  

CESM Software Engineer

leanne.wake@...

Sadly, this didnt work. It is still struggling to find the above links even  with the env variable manually set. Where in the codes does it attempt to link to the HDF5 includes?

Log in or register to post comments

Who's new

  • Nicholas.Davis@...
  • numarsanifa@...
  • bingdian_46@...
  • mxy2832029@...
  • nthg2000@...