Main menu

Navigation

mct corrupt or old module

3 posts / 0 new
Last post
bsf208@...
mct corrupt or old module

I am in the process of building CCSM3 on my Linux Beowulf cluster. I have completed the configuration and ran into some problems with building the MCT that I have solved - i.e. updated to the latest version based on an earlier thread from this group and hardwired in the correct mpif90 version into the configuration file. Now I am getting the following error:

pgf90 -c -DSYSLINUX -DCPRPGI -O2 -pc 64 m_mpout.F90
PGF90-F-0004-Corrupt or Old Module file ./m_stdio.mod (m_mpout.F90: 17)
PGF90/x86-64 Linux 7.2-3: compilation aborted
make[1]: *** [m_mpout.o] Error 2

Has anybody come across this before or have any suggestions?

Ben

bsf208@...

Ok, I solved my own problem. The specific error message I originally encountered was somewhat of a red herring, because when I upgraded to the new version of mct, I did not delete all the previous files in my SCRATCH directory, so there was a bit of a mismatch. However, once everything was cleaned up, the new error message was an inability to locate the MPI header file (mpif.h), so it was a matter of getting the correct setenv. Specifically I had to set the directory paths for the MPI and Netcdf include files and libraries AND the MPIHEADER (and to this I had to add the -I option first) within env_mach.generic_linux. A further error required me to add the -lnetcdff (and -lgfortran) options to SLIBS within Macros.Linux, as well as the correct mpif90 directory path to go with FC. It now builds successfully.

Ben

shanshans@...

Hey Ben,

Could you explain more about solving this problem? I am encountering the same problem now. 

Thank you,

Shanshan 

Log in or register to post comments

Who's new

  • 1658093099@...
  • mborreggine@...
  • kabirtam@...
  • suns@...
  • liangpeng0405@...