Main menu

Navigation

non-existent of input data

12 posts / 0 new
Last post
wrfhelp@...
non-existent of input data

Hi All,

I am running CAM-Chem in CESM using our linux cluster. The compent set of F_2000_STRAMAM3_CN is selected. I got the following error message when I checked the input data during building the case, I would appreciate if some one could help me solve the problem.

Feng

---

:./check_input_data -inputdata

...

svn: URL 'https://svn-ccsm-inputdata.cgd.ucar.edu/trunk/inputdata/atm/cam/chem/ic/...' non-existent in that revision

 

File was not found in svn repo: https://svn-ccsm-inputdata.cgd.ucar.edu/trunk/inputdata/atm/cam/chem/ic/f2000.e12_rel07_chem.STRATMAM3_CN.f19.f19.relv1.cam.i.0011-01-01-00000_c140430.nc

 

  

Feng

tilmes

we added the file to the repository, you may try again to check it out,


Simone

wrfhelp@...

Simone, 

Thank you very mcuh. I got the file successfully after I noticed that it added there. I got the new errors below when I rebuild my case:

   CESM BUILDEXE SCRIPT STARTING

rm: No match.

 COMPILER is pgi

 - Build Libraries: mct gptl pio csm_share 

Thu Feb 12 14:49:13 MST 2015 /home/fliu/cesm1_2_2/work/pgi/mpich2/nodebug/nothreads/mct.bldlog.150212-144907

Thu Feb 12 14:50:26 MST 2015 /home/fliu/cesm1_2_2/work/pgi/mpich2/nodebug/nothreads/gptl.bldlog.150212-144907

Thu Feb 12 14:50:30 MST 2015 /home/fliu/cesm1_2_2/work/pgi/mpich2/nodebug/nothreads/pio.bldlog.150212-144907

ERROR: buildlib.pio failed, see /home/fliu/cesm1_2_2/work/pgi/mpich2/nodebug/nothreads/pio.bldlog.150212-144907

ERROR: cat /home/fliu/cesm1_2_2/work/pgi/mpich2/nodebug/nothreads/pio.bldlog.150212-144907

 ---Please see the file "pio.bldlog.150212-144907.txt" attached. Thank you very much for taking the time to check. Feng  

Feng

tilmes

Hi,

I guess, I cannot help you with this, hopefully someone else can,


Simone

wrfhelp@...

Hi Simone,

The error in my previous post is related to Cmake. It has been fixed after installation of CMAKE. But I still can not pass the build step revceiving the following error message which indicates the buildlib.pio failed, please also see the attached "pio.bldlog.150217-144134.txt". Thanks for your any help.

Feng 

-------------------------------------------------------------------------

 CESM BUILDNML SCRIPT STARTING

 - To prestage restarts, untar a restart.tar file into /home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/run

 infile is /home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/Buildconf/cplconf/cesm_namelist 

CAM writing dry deposition namelist to drv_flds_in 

Writing ocean component namelist to ./docn_in 

CAM writing namelist to atm_in 

CLM configure done.

CLM adding use_case 2000_control defaults for var sim_year with val 2000 

CLM adding use_case 2000_control defaults for var sim_year_range with val constant 

CLM adding use_case 2000_control defaults for var stream_year_first_ndep with val 2000 

CLM adding use_case 2000_control defaults for var stream_year_last_ndep with val 2000 

CLM adding use_case 2000_control defaults for var use_case_desc with val Conditions to simulate 2000 land-use 

CICE configure done.

 CESM BUILDNML SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

-------------------------------------------------------------------------

 CESM PRESTAGE SCRIPT STARTING

 - Case input data directory, DIN_LOC_ROOT, is /home/fliu/cesm1_2_2/inputdata

 - Checking the existence of input datasets in DIN_LOC_ROOT

 CESM PRESTAGE SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

-------------------------------------------------------------------------

 CESM BUILDEXE SCRIPT STARTING

rm: No match.

 COMPILER is pgi

 - Build Libraries: mct gptl pio csm_share 

Tue Feb 17 14:41:40 MST 2015 /home/fliu/cesm1_2_2/work/bin/pgi/mpi/nodebug/nothreads/mct.bldlog.150217-144134

Tue Feb 17 14:42:29 MST 2015 /home/fliu/cesm1_2_2/work/bin/pgi/mpi/nodebug/nothreads/gptl.bldlog.150217-144134

Tue Feb 17 14:42:32 MST 2015 /home/fliu/cesm1_2_2/work/bin/pgi/mpi/nodebug/nothreads/pio.bldlog.150217-144134

ERROR: buildlib.pio failed, see /home/fliu/cesm1_2_2/work/bin/pgi/mpi/nodebug/nothreads/pio.bldlog.150217-144134

 

ERROR: cat /home/fliu/cesm1_2_2/work/bin/pgi/mpi/nodebug/nothreads/pio.bldlog.150217-144134

 

Feng

jedwards
> PGF90-F-0004-Corrupt or Old Module file /usr/local/include/netcdf.mod

This error indicates that netcdf was not built with the same compiler that you are trying to build CESM with.
You may be able to get around this error by adding the flag -DNO_MPIMOD to the CPPFLAGS in your Macros file, if that doesn't work
you will need to build netcdf with the current compiler.

CESM Software Engineer

wrfhelp@...

Thank you very mcuh, jewards - ESM Software Engineer. The problem on NETCDF is fixed  after I re-build netcdf with the same compiler mpif90. Then I ran the model with our Linux cluster and got the following message which indicates the model run is not successfully finsihed. Please also find cesm log file attached. Thanks for taking the time to check and support:

-------------------------------------------------------------------------

 CESM BUILDNML SCRIPT STARTING

 - To prestage restarts, untar a restart.tar file into /home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/run

 infile is /home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/Buildconf/cplconf/cesm_namelist 

CAM writing dry deposition namelist to drv_flds_in 

Writing ocean component namelist to ./docn_in 

CAM writing namelist to atm_in 

CLM configure done.

CLM adding use_case 2000_control defaults for var sim_year with val 2000 

CLM adding use_case 2000_control defaults for var sim_year_range with val constant 

CLM adding use_case 2000_control defaults for var stream_year_first_ndep with val 2000 

CLM adding use_case 2000_control defaults for var stream_year_last_ndep with val 2000 

CLM adding use_case 2000_control defaults for var use_case_desc with val Conditions to simulate 2000 land-use 

CICE configure done.

 CESM BUILDNML SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

-------------------------------------------------------------------------

 CESM PRESTAGE SCRIPT STARTING

 - Case input data directory, DIN_LOC_ROOT, is /home/fliu/cesm1_2_2/inputdata

 - Checking the existence of input datasets in DIN_LOC_ROOT

 CESM PRESTAGE SCRIPT HAS FINISHED SUCCESSFULLY

-------------------------------------------------------------------------

Mon Feb 23 14:24:51 MST 2015 -- CSM EXECUTION BEGINS HERE

Mon Feb 23 14:46:16 MST 2015 -- CSM EXECUTION HAS FINISHED

(seq_mct_drv): ===============       SUCCESSFUL TERMINATION OF CPL7-CCSM ===============

Archiving cesm output to /home/fliu/cesm1_2_2/archive/CAM_chem.MAG.test01

Calling the short-term archiving script st_archive.sh


st_archive.sh: start of short-term archiving

mv: cannot stat `/home/fliu/cesm1_2_2/archive/CAM_chem.MAG.test01/*': No such file or directory

st_archive.sh: restart files from end of run will be saved, 

               interim restart files will be deleted

st_archive.sh: short-term archiving completed successfully

/home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/run/Tools/ccsm_getenv: No such file or directory.

 

gzip: timing/ccsm_timing_stats.150223-142421: No such file or directory

 

Feng

bianqy@...

Hi Feng,

I also met the same problem as you.

/home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/run/Tools/ccsm_getenv: No such file or directory.

gzip: timing/ccsm_timing_stats.150223-142421: No such file or directory

Have you fixed it? How?

Thanks!

----

Qingyun

 

★☆活着,其实就是活一种精神状态~~

tilmes

Could you clarify what the error is you are running into?

 

Thanks, Simone

bianqy@...

We thought,

/home/fliu/cesm1_2_2/work/CAM_chem.MAG.test01/run/Tools/ccsm_getenv: No such file or directory.

gzip: timing/ccsm_timing_stats.150223-142421: No such file or directory

,these were errors!

But actually the run succeeded. I don't understand why these messages appear.

Thanks!

★☆活着,其实就是活一种精神状态~~

holthaum@...

Hi!

Have you a found a solution for the errors in post #7?

I've the same message and I don't know why CESM 1.2.2 tries to look in "run/Tools" for ccsm_getenv.

Thanks!

bianqy@...

Hi,

Me, too.

Have you fixed it?

Thanks!

----

Qingyun

★☆活着,其实就是活一种精神状态~~

Log in or register to post comments

Who's new

  • liuyiling.elaine@...
  • xuzq@...
  • alexander.koch....
  • abalos
  • bleisch@...