Main menu

Navigation

PIO error while trying to generate 3 hour CAM output for CLM spinup

1 post / 0 new
taylor.hughlett@...
PIO error while trying to generate 3 hour CAM output for CLM spinup

Hello all,

We are attempting to output 3 hour CAM data to use with the CPLHIST3HrWx mode in a DATM mode, and I have followed the instructions provided here, but I get a strange error regarding the netCDF write option in cam_history.F90. Here is the error I am getting:

1: Opened file b.e12.B1850CN.f19_g16.cam.h1.0001-01-01-00000.nc to write
1:           6
37: pio_support::pio_die:: myrank=          -1 : ERROR: pionfatt_mod.F90:
37:         170 : NetCDF: Not a valid data type or _FillValue type mismatch
55: pio_support::pio_die:: myrank=          -1 : ERROR: pionfatt_mod.F90:
55:         170 : NetCDF: Not a valid data type or _FillValue type mismatch
1: pio_support::pio_die:: myrank=          -1 : ERROR: pionfatt_mod.F90:
1:         170 : NetCDF: Not a valid data type or _FillValue type mismatch
37:MPT ERROR: Rank 37(g:37) is aborting with error code 1.
37:     Process ID: 5687, Host: r2i4n27, Program: /glade2/scratch2/hughlett/b.e12.B1850CN.f19_g16/bld/cesm.exe
37:     MPT Version: SGI MPT 2.15  09/03/16 04:15:54
37:
37:MPT: --------stack traceback-------
19: pio_support::pio_die:: myrank=          -1 : ERROR: pionfatt_mod.F90:
19:         170 : NetCDF: Not a valid data type or _FillValue type mismatch
1:MPT ERROR: Rank 1(g:1) is aborting with error code 1.
1:      Process ID: 9725, Host: r2i4n22, Program: /glade2/scratch2/hughlett/b.e12.B1850CN.f19_g16/bld/cesm.exe
1:      MPT Version: SGI MPT 2.15  09/03/16 04:15:54
1:
1:MPT: --------stack traceback-------
-1:MPT ERROR: MPI_COMM_WORLD rank 19 has terminated without calling MPI_Finalize()
-1:     aborting job

I saw on another post that the solution was to change this line in cam_history.F90

if (tape(t)%hlist(f)%hwrt_prec == 8) then

to

if ((tape(t)%hlist(f)%hwrt_prec == 8) .or. restart) then

so I jumped into cam_history.F90 to change it. However, it has already been changed and I am still getting the above error. I've not worked with PIO much, so I'm out of my element here. Any help would be greatly appreciated. My case is located at the following path:

/glade/p/work/hughlett/cheyenne/b.e12.B1850CN.f19_g16

Thanks in advance!! 

Taylor M. Hughlett, Ph.D.
Postdoctoral Research Fellow
Department of Earth & Environmental Sciences
University of Texas at Arlington

Who's new

  • Nicholas.Davis@...
  • numarsanifa@...
  • bingdian_46@...
  • mxy2832029@...
  • nthg2000@...