Main menu

Navigation

pnetcdf requirement for 1.2.2

3 posts / 0 new
Last post
aketh.tm@...
pnetcdf requirement for 1.2.2

The cesm 1.2.2 version requires Pnetcdf as per the user manual.

 

However as per the a reply i got on the forum it is not required as per one of your software engineer's and optional (even for the 1.2.2 version). Can the team clarify this confusion.

 

Here is the link to the post i am talking about.

 

https://bb.cgd.ucar.edu/cesm-runtime-error-netcdf-invalid-dimension-id-o...

jedwards

PNETCDF is not required for CESM however if you want to use pnetcdf version 1.4.0 or newer is required.

CESM Software Engineer

nitkbhat@...

I have PNETCDF 1.4.0 installed. I have also installed hdf5 1.8.8, netcdf 4.3.1.1 and netcdf fortran 4.4.0. 

I have set the path to this in the environment variables and also added it to the macros. 

I have successfully built CESM 1.2.2 with pnetcdf. 

However, when I run it, I get the following error: 

 

https://bb.cgd.ucar.edu/using-pnetcdf-cesm

 

What should I configure for getting pnetcdf to work with CESM? 

Thanks.

Log in or register to post comments

Who's new

  • praveenmaniyatt@...
  • arjunbabun11@...
  • lama@...
  • sisi393@...
  • 1658093099@...