Main menu

Navigation

problem with MERRA files running FSTRATMAM7

1 post / 0 new
adriana.bossola...
problem with MERRA files running FSTRATMAM7

Hi evryone

I was using the FSTRATMAM7 compset ( 2000_CAM5%SMA7_CLM40%CN_CICE%PRES_DOCN%DOM_RTM_SGLC_SWAV) the model run well even with my emission files, but then when I try to add the nudging files from MERRA doesn't works and I get the next error:

QNEG3 from chemistry/SO2:m=126 lat/lchnk=    137 Min. mixing ratio violated at    2 points.  Reset to  1.0E-36 Worst =-1.8E-12 at i,k=  16 28
 QNEG3 from chemistry/NH3:m=128 lat/lchnk=    655 Min. mixing ratio violated at    4 points.  Reset to  1.0E-36 Worst =-1.6E-12 at i,k=  16 26
 QNEG3 from chemistry/SO2:m=126 lat/lchnk=    473 Min. mixing ratio violated at    2 points.  Reset to  1.0E-36 Worst =-7.8E-12 at i,k=   8 25
 QNEG3 from chemistry/NH3:m=128 lat/lchnk=    473 Min. mixing ratio violated at    9 points.  Reset to  1.0E-36 Worst =-9.9E-12 at i,k=  16 25
forrtl: error (65): floating invalid
Image              PC                Routine            Line        Source
cesm.exe           00000000072D3851  Unknown               Unknown  Unknown
cesm.exe           00000000072D1FA7  Unknown               Unknown  Unknown
cesm.exe           000000000726DE94  Unknown               Unknown  Unknown
cesm.exe           000000000726DCA6  Unknown               Unknown  Unknown
cesm.exe           00000000071FBB0F  Unknown               Unknown  Unknown
cesm.exe           0000000007205464  Unknown               Unknown  Unknown
libpthread.so.0    00002AAAAC0CA7E0  Unknown               Unknown  Unknown
libnetcdf.so.7     00002AAAAB0E3B55  Unknown               Unknown  Unknown
cesm.exe           000000000124A2E9  mo_neu_wetdep_mp_        1698  mo_neu_wetdep.F90
cesm.exe           000000000122B3B1  mo_neu_wetdep_mp_         839  mo_neu_wetdep.F90
cesm.exe           00000000012115DD  mo_neu_wetdep_mp_         380  mo_neu_wetdep.F90
cesm.exe           000000000091DEAB  chemistry_mp_chem        1460  chemistry.F90
cesm.exe           0000000001B06AA5  physpkg_mp_tphysa        1396  physpkg.F90
cesm.exe           0000000001AFE72A  physpkg_mp_phys_r        1131  physpkg.F90
cesm.exe           00000000006F6884  cam_comp_mp_cam_r         300  cam_comp.F90
cesm.exe           00000000006BD275  atm_comp_mct_mp_a         539  atm_comp_mct.F90
cesm.exe           00000000004B2C12  ccsm_comp_mod_mp_        4079  ccsm_comp_mod.F90
cesm.exe           00000000004C2C42  MAIN__                     91  ccsm_driver.F90
cesm.exe           00000000004147BE  Unknown               Unknown  Unknown
libc.so.6          00002AAAAC2F7D1D  Unknown               Unknown  Unknown
cesm.exe           0000000000414649  Unknown               Unknown  Unknown
 --------------------------------------------------------------------------
mpirun noticed that process rank 57 with PID 59628 on node node03 exited on signal 6 (Aborted).
--------------------------------------------------------------------------

I tought that maybe was a problem of the compset, so I create a new one (with sucess) replaced 2000 by GEOS like this: GEOS_CAM5%SMA7_CLM40%CN_CICE%PRES_DOCN%DOM_RTM_SGLC_SWA

But I also get more or less the same error when I put my MEERA files:

nspec=           3
 l=           1 vol(l)=  2.224293719505140E-007
 isw=           8 specrefindex(isw)= (1.52999997138977,4.040892235934734E-003)
 specdens=   2600.00000000000
 l=           2 vol(l)=  6.238961179983955E-016
 isw=           8 specrefindex(isw)= (1.42163205146790,1.751226818669238E-006)
 specdens=   1770.00000000000
 l=           3 vol(l)=  2.342781732360044E-016
 isw=           8 specrefindex(isw)= (1.42163205146790,1.751226818669238E-006)
 specdens=   1770.00000000000
 QNEG3 from TPHYSBCb:m=152 lat/lchnk=    257 Min. mixing ratio violated at    1 points.  Reset to  1.0E-36 Worst =-5.8E+01 at i,k=  11  1
forrtl: error (65): floating invalid
Image              PC                Routine            Line        Source
cesm.exe           00000000072D3851  Unknown               Unknown  Unknown
cesm.exe           00000000072D1FA7  Unknown               Unknown  Unknown
cesm.exe           000000000726DE94  Unknown               Unknown  Unknown
cesm.exe           000000000726DCA6  Unknown               Unknown  Unknown
cesm.exe           00000000071FBB0F  Unknown               Unknown  Unknown
cesm.exe           0000000007205464  Unknown               Unknown  Unknown
libpthread.so.0    00002AAAAC0CA7E0  Unknown               Unknown  Unknown
libnetcdf.so.7     00002AAAAB0E3B55  Unknown               Unknown  Unknown
cesm.exe           00000000064000BA  soiltemperaturemo        1052  SoilTemperatureMod.F90
cesm.exe           00000000063D577B  soiltemperaturemo         543  SoilTemperatureMod.F90
cesm.exe           0000000005D22350  biogeophysics2mod         281  Biogeophysics2Mod.F90
cesm.exe           00000000056E3A0C  clm_driver_mp_clm         531  clm_driver.F90
cesm.exe           0000000005657F4B  lnd_comp_mct_mp_l         589  lnd_comp_mct.F90
cesm.exe           0000000000490E1F  ccsm_comp_mod_mp_        3281  ccsm_comp_mod.F90
cesm.exe           00000000004C2C42  MAIN__                     91  ccsm_driver.F90
cesm.exe           00000000004147BE  Unknown               Unknown  Unknown
libc.so.6          00002AAAAC2F7D1D  Unknown               Unknown  Unknown
cesm.exe           0000000000414649  Unknown               Unknown  Unknown
--------------------------------------------------------------------------
mpirun noticed that process rank 42 with PID 88825 on node node04 exited on signal 6 (Aborted).
--------------------------------------------------------------------------
                                                                                                   

 I don't realize where is the problem.... the cesm.log file always print this kind of error

It is possible that MAM7 have problems with nudging files??? How I can look more specifically the problem?


I really appreciate any help!

Who's new

  • kamal.tewari1@...
  • rchemke
  • abdulla.sakalli@...
  • mehmetugurgucel@...
  • borst