Main menu

Navigation

seq_domain_check atm/lnd domain error

1 post / 0 new
iccp.stein@...
seq_domain_check atm/lnd domain error

Hello paleo modelers,

 

I am attempting to set up a fully coupled (compset B) LGM run with resolution T31_g37, and I am getting a really baffling error.

The model run aborts at the (seq_domain_check_grid) subroutine when comparing the atm/lnd domains. From the cpl.log:

(seq_domain_check)  --- checking atm/land domains ---

(seq_domain_check_grid)  the domain size is =           42

(seq_domain_check_grid)  maximum           difference for lat  0.132663573992886E-05

(seq_domain_check_grid)  maximum allowable difference for lat  0.100000000000000E-11

 (seq_domain_check_grid) ERROR: incompatible domain grid coordinates

(shr_sys_abort) ERROR: (seq_domain_check_grid)  incompatible domain grid coordinates

(shr_sys_abort) WARNING: calling shr_mpi_abort() and stopping

 

This is despite the fact that the atm and land domains are the same! From the evn_run.xml:

<entry id="ATM_DOMAIN_FILE"   value="domain.lnd.T31_g37PD.190708.nc"  />    

<entry id="ATM_DOMAIN_PATH"   value="/home/kstein/ICESM/paleo_setup/cesm1/cpl_mapping/maps"  />    

<entry id="LND_DOMAIN_FILE"   value="domain.lnd.T31_g37PD.190708.nc"  />    

<entry id="LND_DOMAIN_PATH"   value="/home/kstein/ICESM/paleo_setup/cesm1/cpl_mapping/maps"  />    

 

And it does in fact seem that the atmosphere and land domains are being compared, not the atm/lnd (i.e. same) domain is being compared to something else. From the seq_domain_mct module:

call seq_domain_check_grid(atmdom_a%data, lnddom_a%data, 'lat' , eps=eps_axgrid, mpicom=mpicom_a, mask=maskl)

 Can anyone explain this? Thanks for the help,Karl 

Who's new

  • stans
  • ahadibfar@...
  • jskang@...
  • divanova@...
  • mrostami@...