Main menu

Navigation

Simulation of an aquaplanet with WACCM

3 posts / 0 new
Last post
luoyangcheng96@...
Simulation of an aquaplanet with WACCM

Hi everyone,

 

I'm trying to change the ocean/land distribution in CESM to make an aquaplanet with WACCM. Currently I'm using the compset F_1850_WACCM. I have modified all the nc files containing information about the land mask and topography in env_run.xml and in the namelists, and have redirected all the pointers to the modified files. But the model can't start up anyway. In the cesm.log file, error information is as following:

 

 (seq_map_avNormAvF)  ERROR: lsize_i ne lsize_f            0       11269
(shr_sys_abort) ERROR: (seq_map_avNormAvF)  ERROR size_i ne lsize_f
(shr_sys_abort) WARNING: calling shr_mpi_abort() and stopping

...

MCT::m_AttrVect::lsize_: attribute array length mismatch error, stat =-4
011.MCT(MPEU)::die.: from MCT::m_AttrVect::lsize_()

...

MCT::m_MatAttrVectMul::sMatAvMult_SMPlus_:: FATAL ERROR--parallelization strategy name  not supported.

...

006.MCT(MPEU)::die.: from MCT::m_MatAttrVectMul::sMatAvMult_SMPlus_()

...

 

I want to know what these errors mean and how to fix them. And can I make an aquaplanet by simply finding out the relevant nc files and modifying them in the compset F_1850_WACCM?

 

Thank you very much.

 

Yangcheng

jedwards

You didn't say what version of the model you are using.   The model already supports an aquaplanent mode which still reads the land mask but then ignores it internally.   I think that starting from that existing aquaplanet and extending it to incorporate WACCM would be an easier approach than the one you are currently attempting.  

CESM Software Engineer

luoyangcheng96@...

Thank you very much. Currently I'm using CESM 1.2.2. And I have already noticed that there are FC4AQUAP and FC5AQUAP compsets that provide an aquaplanet configuration. However, I don't know how to combine them with WACCM. I have already tried to add WACCM to FC5AQUAP compset by adding "-chem waccm_mozart" to CAM_CONFIG_OPTS in env_build.xml, but it couldn't start and reported the error message:

(shr_sys_abort) ERROR: flbc_inti: cannot specify both co2vmr and CO2 in flbc_file

Could you please tell me how to fix this problem? And I'm not sure what else I need to do to add WACCM to FC5AQUAP or FC4AQUAP, because it seems they have different numbers of levels!

Thank you very much!

Log in or register to post comments

Who's new

  • rory
  • dangcheng111@...
  • yuxisuo2020@...
  • bryn.ronalds@...
  • brookeadams@...