Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Error dt limit for stream by CRUNCEP forcing data

syang

Shawn Yang
New Member
Hi all,
I have successfully run CLM model with GSWP3v1 forcing data (3hrly) and my own lnd.domain file (long=110, lat=40, nx=ny=96, dx=dy=6) and surface_map. However, when I try to use Cruncep forcing data (6hrly,"atm_forcing.datm7.cruncep_qianFill.0.5d.v7.c160715"), it failed. The error "dt limit for stream" came out using Cruncep data.
I created the case using the compsets "I2000Clm50BgcCruGs". I noticed the only difference between GWSP3v1 data and Cruncep data is the temporal resolution. I do not know why this error came out and how to fix it.
I attached the cesm.log, atm.log and stream files below.
Does anyone can help me with this? THANKS!!!
 

Attachments

  • datm.streams.txt.CLMCRUNCEPv7.TPQW.png
    datm.streams.txt.CLMCRUNCEPv7.TPQW.png
    100.4 KB · Views: 5
  • datm.streams.txt.CLMCRUNCEPv7.Solar.png
    datm.streams.txt.CLMCRUNCEPv7.Solar.png
    98.5 KB · Views: 4
  • datm.streams.txt.CLMCRUNCEPv7.PRECIP.png
    datm.streams.txt.CLMCRUNCEPv7.PRECIP.png
    99.8 KB · Views: 5
  • datm_in.png
    datm_in.png
    66.9 KB · Views: 6
  • atmlog.png
    atmlog.png
    181.3 KB · Views: 6
  • cesmlog.png
    cesmlog.png
    110.3 KB · Views: 6

oleson

Keith Oleson
CSEG and Liaisons
Staff member
In cesm2.1.3, that compset comes out of the box with:

streams = "datm.streams.txt.CLMCRUNCEPv7.Solar 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.Precip 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.TPQW 1991 1991 2010",
"datm.streams.txt.presaero.clim_2000 1 2000 2000",
"datm.streams.txt.topo.observed 1 1 1"

and runs fine.

It looks like you've changed the datm settings so that you loop over 1901 only (judging from your datm.streams.txt.* files and your datm_in). But the atm log indicates the model is starting at year 2000 and you are reading in year 2000 data. That doesn't seem consistent.
What are your settings for:

RUN_STARTDATE
DATM_CLMNCEP_YR_ALIGN
DATM_CLMNCEP_YR_START
DATM_CLMNCEP_YR_END

Also, can you attach your entire atm log?
 

syang

Shawn Yang
New Member
In cesm2.1.3, that compset comes out of the box with:

streams = "datm.streams.txt.CLMCRUNCEPv7.Solar 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.Precip 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.TPQW 1991 1991 2010",
"datm.streams.txt.presaero.clim_2000 1 2000 2000",
"datm.streams.txt.topo.observed 1 1 1"

and runs fine.

It looks like you've changed the datm settings so that you loop over 1901 only (judging from your datm.streams.txt.* files and your datm_in). But the atm log indicates the model is starting at year 2000 and you are reading in year 2000 data. That doesn't seem consistent.
What are your settings for:

RUN_STARTDATE
DATM_CLMNCEP_YR_ALIGN
DATM_CLMNCEP_YR_START
DATM_CLMNCEP_YR_END

Also, can you attach your entire atm log?
Hi Oleson,

Thank you for your reply. I was trying to run year 1901 as a case test that I did the same thing for GSWP data. My RUN_STARTDATE is 1901-01-01, running 5 days.
DATM_CLMNCEP_YR_ALIGN = 1901
DATM_CLMNCEP_YR_START= 1901
DATM_CLMNCEP_YR_END= 1901

I think it might be date-setting problem. But I do not know how to set up. For the GSWP data, I did

"./xmlchange --file env_run.xml --id RUN_STARTDATE --val 190101-01
./xmlchange --file env_run.xml --id DATM_CLMNCEP_YR_START --val 1901
./xmlchange --file env_run.xml --id DATM_CLMNCEP_YR_END --val 1901"
and it worked.

I attached the atm.log, cesm.log as well as env_run.xml below. THANKS!
 

Attachments

  • atm.log.1519772.210322-143730.txt
    14.8 KB · Views: 3
  • cesm.log.1519772.210322-143730.txt
    10.2 KB · Views: 2
  • env_run.xml.txt
    64.2 KB · Views: 3

syang

Shawn Yang
New Member
In cesm2.1.3, that compset comes out of the box with:

streams = "datm.streams.txt.CLMCRUNCEPv7.Solar 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.Precip 1991 1991 2010",
"datm.streams.txt.CLMCRUNCEPv7.TPQW 1991 1991 2010",
"datm.streams.txt.presaero.clim_2000 1 2000 2000",
"datm.streams.txt.topo.observed 1 1 1"

and runs fine.

It looks like you've changed the datm settings so that you loop over 1901 only (judging from your datm.streams.txt.* files and your datm_in). But the atm log indicates the model is starting at year 2000 and you are reading in year 2000 data. That doesn't seem consistent.
What are your settings for:

RUN_STARTDATE
DATM_CLMNCEP_YR_ALIGN
DATM_CLMNCEP_YR_START
DATM_CLMNCEP_YR_END

Also, can you attach your entire atm log?
Hi Oleson,

I tried to change the start date, end date as well as align data. But the case with CRUNCEP data is still not working. The atm.log and env_run.xml are attached above. Could you help me with that? THANKS!
 

oleson

Keith Oleson
CSEG and Liaisons
Staff member
Your settings of RUN_STARTDATE, DATM_CLMNCEP_YR_ALIGN, DATM_CLMNCEP_YR_START, and DATM_CLMNCEP_YR_END look correct in the env_run.xml you attached. I can run successfully with those settings.
One difference I see between your atm log and mine is during the the reading in of the datm_in file.
Your atm log shows this for, e.g., the Solar stream:

(shr_strdata_print) streams ( 1) = datm.streams.txt.CLMCRUNCEPv7.Solar 2000 2000 2000
(shr_strdata_print) taxMode ( 1) = cycle
(shr_strdata_print) dtlimit ( 1) = 1.500000E+00
(shr_strdata_print) strnxg ( 1) = 720
(shr_strdata_print) strnyg ( 1) = 360

whereas mine shows:

(shr_strdata_print) streams ( 1) = datm.streams.txt.CLMCRUNCEPv7.Solar 1901 1901 1901
(shr_strdata_print) taxMode ( 1) = cycle
(shr_strdata_print) dtlimit ( 1) = 1.500000E+00
(shr_strdata_print) strnxg ( 1) = 720
(shr_strdata_print) strnyg ( 1) = 360

So yours seems to be ignoring the settings you made to loop over 1901, while mine is correct.
You attached your datm_in previously which shows 1901.
Is that the datm_in in your run directory? Maybe you are reading in a datm_in from another location somehow.

Otherwise, I'm not sure what to suggest other than to start over beginning at create_newcase.
I'm sorry that I don't see what the problem is right now.
 

syang

Shawn Yang
New Member
Your settings of RUN_STARTDATE, DATM_CLMNCEP_YR_ALIGN, DATM_CLMNCEP_YR_START, and DATM_CLMNCEP_YR_END look correct in the env_run.xml you attached. I can run successfully with those settings.
One difference I see between your atm log and mine is during the the reading in of the datm_in file.
Your atm log shows this for, e.g., the Solar stream:

(shr_strdata_print) streams ( 1) = datm.streams.txt.CLMCRUNCEPv7.Solar 2000 2000 2000
(shr_strdata_print) taxMode ( 1) = cycle
(shr_strdata_print) dtlimit ( 1) = 1.500000E+00
(shr_strdata_print) strnxg ( 1) = 720
(shr_strdata_print) strnyg ( 1) = 360

whereas mine shows:

(shr_strdata_print) streams ( 1) = datm.streams.txt.CLMCRUNCEPv7.Solar 1901 1901 1901
(shr_strdata_print) taxMode ( 1) = cycle
(shr_strdata_print) dtlimit ( 1) = 1.500000E+00
(shr_strdata_print) strnxg ( 1) = 720
(shr_strdata_print) strnyg ( 1) = 360

So yours seems to be ignoring the settings you made to loop over 1901, while mine is correct.
You attached your datm_in previously which shows 1901.
Is that the datm_in in your run directory? Maybe you are reading in a datm_in from another location somehow.

Otherwise, I'm not sure what to suggest other than to start over beginning at create_newcase.
I'm sorry that I don't see what the problem is right now.
Hi Oleson,

Thank you for the updates. I think the problem should be what you said about ignoring the settings of 1901. I will create a new case to see what will happen.
 
Top