Scheduled Downtime
On Wednesday 09 March 2022 from 6am to 10am MT, the website will be down for maintenance

ERROR: Expected one child

Liu W

liuwei
New Member
Hello, Sir or Madam. When I am porting CESM2.1.3 to HPC with linux, I get error "ERROR: Expected one child". With the tutorials about CESM porting, I have added reasonable settings for my machines in ~/my_cesm_sandbox/cime/config/cesm/machines/config_machines.xml and config_compilers.xml in same folder(there isn't /.cime in $HOME). When I run "./create_newcase --case testbylw --compset X --res f19_g16 --mach IGG", I get this error. Config_machines.xml and config_compilers.xml have been attached, with the bashrc(for environment_variables) and version_info.
Appreciate any reply!
 

Attachments

  • ERROR.png
    ERROR.png
    92.7 KB · Views: 23
  • bashrc.txt
    4.1 KB · Views: 5
  • version_info.txt
    4.7 KB · Views: 5

Liu W

liuwei
New Member
SORRY.These are files
 

Attachments

  • config_compilers.txt
    4.6 KB · Views: 12
  • config_machines.txt
    4.5 KB · Views: 14

jedwards

CSEG and Liaisons
Staff member
You are not supposed to replace the distributed config_machines.xml or config_compilers.xml. You can add your changes to the existing files or
create a directory $HOME/.cime and add them there. Files in $HOME/.cime are appended to the files from the distribution.
 

Liu W

liuwei
New Member
You are not supposed to replace the distributed config_machines.xml or config_compilers.xml. You can add your changes to the existing files or
create a directory $HOME/.cime and add them there. Files in $HOME/.cime are appended to the files from the distributt
Thanks for your answer. I have solved this problem. But when I were building a case with the code "./case.build", I have gotten the error(
Calling /public/home/fshi/model/soft/CESM/my_cesm_sandbox/cime/src/build_scripts/buildlib.pio
ERROR: /public/home/fshi/model/soft/CESM/my_cesm_sandbox/cime/src/build_scripts/buildlib.pio FAILED, cat /public/home/fshi/model/CESM2_OUTPUT/testbylw/bld/pio.bldlog.210101-164223
), and the list below is the "pio.bldlog.210101-164223". Looking forward to your reply and Happy New Year!
 

Attachments

  • pio.bldlog.210101-164223.txt
    30.8 KB · Views: 9

jedwards

CSEG and Liaisons
Staff member
It looks like you are trying to link a netcdf fortran library built with gfortran with a pio built with intel fortran. These need to use the same compiler.
 

Liu W

liuwei
New Member
It looks like you are trying to link a netcdf fortran library built with gfortran with a pio built with intel fortran. These need to use the same compiler.
Thanks. With your suggestion, I have solved this problem. But when I submitted newcase with PBS, I found the job can't run. I simplify my code, and when I used creat_newcase, I received "Batch_system_type is pbs ERROR: No batch system 'pbs' found". I can't find same error in forum. Below are .xml files. Thanks for your help!
 

Attachments

  • config_mach+compilers+batch.xml.txt
    4 KB · Views: 11

Liu W

liuwei
New Member
Is that file in the .cime directory, or did you overwrite the default version?
Yeah, I overwrited the default version in /cime/config/cesm/machines/. With your suggestion, I creat ./cime and move these files to the directory, and recover the default files. Now the error have been repaired. Thank you!
 

Liu W

liuwei
New Member
You should just need it for FFLAGS.
Is that file in the .cime directory, or did you overwrite the default version?
Hi, jedwards. I encounter the same problem in the quote when I run my case B1850cmip6. I have add "-fconvert=big-endian ", but the problem haven't been solved. Here are the Macros.make and cesm.log. Do you have any suggestion?
 

Attachments

  • cesm.log.txt
    153.6 KB · Views: 3
  • Macros.make.txt
    974 bytes · Views: 2

jedwards

CSEG and Liaisons
Staff member
You need to look in the ocn.bldlog to see if the flag is included there, it should be. Otherwise post to the pop ocn forum.
 

Liu W

liuwei
New Member
You need to look in the ocn.bldlog to see if the flag is included there, it should be. Otherwise post to the pop ocn forum.
Firstly, thanks for your reply. I have checked the ocn.bldlog, there are much warning information like"ifort: command line warning #10006: ignoring unknown option '-fconvert=big-endian'". Could you tell me where the mistake may be created?
 

Liu W

liuwei
New Member
According to the ifort man page the flag you are looking for is -convert big_endian
You are right. The error have been solved. And I get an new error, it's too late to search in the forum, now it's midnight. The error in cesm.log is
===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= RANK 1 PID 295556 RUNNING AT Mars26
= KILLED BY SIGNAL: 9 (Killed)
===================================================================================

===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= RANK 2 PID 295557 RUNNING AT Mars26
= KILLED BY SIGNAL: 9 (Killed)
=========================================================
I guess it mean no problem for CESM, am I right? THANKS
 

jedwards

CSEG and Liaisons
Staff member
This indicates that your job was killed by some external process, check with your system administrators.
 

Liu W

liuwei
New Member
This indicates that your job was killed by some external process, check with your system administrators.
Hi,jedwards. With the forums and your help, I can run the case BW1850cmip without error.However, I run the case B1850cmip6 and get the error in cesm.log(pio_support::pio_die:: myrank= -1 : ERROR: ionf_mod.F90: 235 : NetCDF: Attempt to use feature that was not turned on when netCDF was built.). And there are two warning messages in piobldlog"
/cime/src/externals/pio1/pio/piolib_mod.F90(2243): warning #6843: A dummy argument with an explicit INTENT(OUT) declaration is not given an explicit value. [IOPROC] subroutine pio_recommend_iotasks(comm, ioproc, numiotasks, miniotasks, maxiotasks )
/cime/src/externals/pio1/pio/piolib_mod.F90(2243): warning #6843: A dummy argument with an explicit INTENT(OUT) declaration is not given an explicit value. [NUMIOTASKS] subroutine pio_recommend_iotasks(comm, ioproc, numiotasks, miniotasks, maxiotasks )". Do you have any suggestion? The version of netcdf is 4.7.2 and pnetcdf is 1.12.1. Thank you!
 

Liu W

liuwei
New Member
In addition, when add FFLAGS := $(FFLAGS) -assume byterecl, I have solved the problem "= KILLED BY SIGNAL: 9 (Killed)" because of incomplete of reading file.
 

jedwards

CSEG and Liaisons
Staff member
The warnings are expected and not of concern. The error may mean that you are trying to read a netcdf4 file without support in the netcdf library. Using nc-config make sure that you have hdf5 on in the netcdf build.
 

Liu W

liuwei
New Member
The warnings are expected and not of concern. The error may mean that you are trying to read a netcdf4 file without support in the netcdf library. Using nc-config make sure that you have hdf5 on in the netcdf build.
I have install HDF5 before netcdf, and nc-config also told that the netcdf support netcdf4 format. I have attached the information of cdf configuration. And I found I encounter an error in cesm.log after getting four-day cice output data of BW1850cmip6 ([mpiexec@Mars25] wait_proxies_to_terminate (../../../../../src/pm/i_hydra/mpiexec/intel/i_mpiexec.c:532): downstream from host Mars25 was killed by signal 15 (Terminated) [mpiexec@Mars25] main (../../../../../src/pm/i_hydra/mpiexec/mpiexec.c:2114): assert (exitcodes != NULL) failed). I don't know whether they indicate the same error.
 

Attachments

  • netcdf&pnetcdf.txt
    4.2 KB · Views: 3

ykp990521

ykp990521
Member
Yeah, I overwrited the default version in /cime/config/cesm/machines/. With your suggestion, I creat ./cime and move these files to the directory, and recover the default files. Now the error have been repaired. Thank you!
Hello, i encountered the same problem when porting CESM2.2 (No batch system found...), but after I created ./cime and move _machines _batch _pes and _compiler, recovering default files, it showed Multiple matches for name 'default_run_suffix' and attribs 'None' in file, could you help me with it? Thanks a lot!
 

jedwards

CSEG and Liaisons
Staff member
Just remove this from your .cime/config_machines.xml :

<default_run_suffix>
<default_run_exe>${EXEROOT}/cesm.exe </default_run_exe>
<default_run_misc_suffix> >> cesm.log.$LID 2>&amp;1 </default_run_misc_suffix>
</default_run_suffix>
 
Top