Scheduled Downtime
On Wednesday 09 March 2022 from 6am to 10am MT, the website will be down for maintenance

ERROR: Expected one child

Xiaoyun W

Xiaoyun Wang
New Member
You are right. The error have been solved. And I get an new error, it's too late to search in the forum, now it's midnight. The error in cesm.log is
===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= RANK 1 PID 295556 RUNNING AT Mars26
= KILLED BY SIGNAL: 9 (Killed)
===================================================================================

===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= RANK 2 PID 295557 RUNNING AT Mars26
= KILLED BY SIGNAL: 9 (Killed)
=========================================================
I guess it mean no problem for CESM, am I right? THANKS
I have the same problem. What causes it? How can I solve this problem?Appreciate your reply!
 

Liu W

liuwei
New Member
I have the same problem. What causes it? How can I solve this problem?Appreciate your reply!
You should check other specific error messages in the log files. If you see the message(forrtl: severe (36): attempt to access non-existent record, unit 86, file......), the error may result from the complier configuration, and I think you should add the line "FFLAGS := $(FFLAGS) -assume byterecl" in your config_compilers.xml.
 

Xiaoyun W

Xiaoyun Wang
New Member
Thank you for your answer. I didn't meet this question, but I met another one: forrtl: error (76): Abort trap signal
Do you know how to solve this problem?Looking forward to your reply!
 

Xiaoyun W

Xiaoyun Wang
New Member
You should check other specific error messages in the log files. If you see the message(forrtl: severe (36): attempt to access non-existent record, unit 86, file......), the error may result from the complier configuration, and I think you should add the line "FFLAGS := $(FFLAGS) -assume byterecl" in your config_compilers.xml.

How did you find this solution? Do I need to contact the server administrator?
 

jedwards

CSEG and Liaisons
Staff member
Error in the log file suggests that there is a mismatch between the hdf5 library you are linking and the one that was used to build netcdf.
Use nc-config -a to learn what hdf5 was used in building netcdf and use it to link cesm. If you are loading through modules you should report the
issue to your modules administrator.
 
Top