Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Modifying prescribed SST in aquaplanet

zhsong

Zihan Song
New Member
Hi, everyone!

I'm running the CAM4 aqua-planet case. I tried to modify the prescribed SST by displacing the value of variable SSTICE_DATA_FILENAME in env_run.xml with the file path linking to the SST NCfile created myself.(The SST in NCfile is named as SST_cpl).

The buildup was completed successfully, however the SST forcing was still as the default.
Is the only way to modify the SST forcing is by modifying the F90 code in aqua-planet case?

Any answer will be of great help to me and I will be very grateful!

1606216439583.png
 

brianpm

Member
I'm assuming you are using some version of CESM2, which will make this easier.

It looks like the user's guide, 4. Atmospheric configurations (compsets) — camdoc documentation, is incorrect in how to set up this case.

Here is how to use your own SST file with aquaplanet configuration (using CESM2.2 in this case):

./create_newcase
--case /path/to/test_cases/q.e2.cam4.fv2.sstfile
--compset 2000_CAM40_SLND_SICE_DOCN%AQPFILE_SROF_SGLC_SWAV_SIAC_SESP
--res f19_f19_mg17
--project PXXXXXX
--run-unsupported

The important thing here is the "_DOCN%AQPFILE" which says to use aquaplanet settings with SST specified in a file.

For CAM4, FV-2°, there should be a default SST file that gets used for this case. Change to the case directory and you can see it with:

> ./xmlquery -p DOCN_MODE
DOCN_MODE: sst_aquapfile
> ./xmlquery -p DOCN_AQP_FILENAME
DOCN_AQP_FILENAME: sst_c4aquasom_0.9x1.25_clim.c170512.nc

To change to another file, you need to change DOCN_AQP_FILENAME.

BUT NOTE that you will probably have to:
- run case.setup and preview_namelists
- copy CaseDocs/docn.streams.txt.aquapfile into the main case directory and call it user_docn.streams.txt.aquapfile
- edit that file, changing the filePath and fileNames entries (twice each) to match your file path and name
- run preview_namelists again to capture the change
- confirm that the CaseDocs/docn.streams.txt.aquapfile has the correct file specified

This is a bug that hasn't been fixed yet.

At this point you should be able to build and run the model.
 

zhsong

Zihan Song
New Member
I'm assuming you are using some version of CESM2, which will make this easier.

It looks like the user's guide, 4. Atmospheric configurations (compsets) — camdoc documentation, is incorrect in how to set up this case.

Here is how to use your own SST file with aquaplanet configuration (using CESM2.2 in this case):

./create_newcase
--case /path/to/test_cases/q.e2.cam4.fv2.sstfile
--compset 2000_CAM40_SLND_SICE_DOCN%AQPFILE_SROF_SGLC_SWAV_SIAC_SESP
--res f19_f19_mg17
--project PXXXXXX
--run-unsupported

The important thing here is the "_DOCN%AQPFILE" which says to use aquaplanet settings with SST specified in a file.

For CAM4, FV-2°, there should be a default SST file that gets used for this case. Change to the case directory and you can see it with:

> ./xmlquery -p DOCN_MODE
DOCN_MODE: sst_aquapfile
> ./xmlquery -p DOCN_AQP_FILENAME
DOCN_AQP_FILENAME: sst_c4aquasom_0.9x1.25_clim.c170512.nc

To change to another file, you need to change DOCN_AQP_FILENAME.

BUT NOTE that you will probably have to:
- run case.setup and preview_namelists
- copy CaseDocs/docn.streams.txt.aquapfile into the main case directory and call it user_docn.streams.txt.aquapfile
- edit that file, changing the filePath and fileNames entries (twice each) to match your file path and name
- run preview_namelists again to capture the change
- confirm that the CaseDocs/docn.streams.txt.aquapfile has the correct file specified

This is a bug that hasn't been fixed yet.

At this point you should be able to build and run the model.

Thanks for your reply.

The version I used is CESM1.2.2 in fact, and the compset is FC4AQUAP. It seems that the prescribed SST can be modified only in the ocn_comp.F90 rather than a given SST file(Simpler Models | Aquaplanet | Fixed-SST Configurations (ucar.edu)).

I will try to use the CESM2, thank you very much for your help.
 
In CESM2, I tried to modify the prescribed SST by changing the value of variable SSTICE_DATA_FILENAME in env_run.xml with the file path linking to the SST NCfile created myself.

I did the following

./create_newcase --case /global/homes/w/xxx/my_cesm_sandbox/cases/Aqua_SST1_test --compset QPC6 --res f19_f19_mg17
cd ~/my_cesm_sandbox/cases/Aqua_SST1_test

./xmlchange DOCN_MODE=sst_aquapfile
./xmlchange DOCN_AQP_FILENAME=/global/homes/w/xxx/my_cesm_sandbox/input_data/sst_HadOIBl_bc_1.9x2.5_aqua_c180511.nc

./case.setup

./case.build

However, I find that the file CaseDocs/docn.streams.txt.aquapfile writes

</variableNames>
<filePath>
/project/projectdirs/ccsm1/inputdata/ocn/docn7/AQUAPLANET/
</filePath>
<fileNames>
/global/homes/w/wenyuz/my_cesm_sandbox/input_data/sst_HadOIBl_bc_1.9x2.5_aqua_c180511.nc
</fileNames>


This is not what I expect as

</variableNames>
<filePath>
/global/homes/w/wenyuz/my_cesm_sandbox/input_data/
</filePath>
<fileNames>
sst_HadOIBl_bc_1.9x2.5_aqua_c180511.nc
</fileNames>

As a result, the job fails with not finding the file. I note, for F2000clim experiment, the docn.streams.txt.prescribed is OK, the same as what I expect above.

I tried to manually change the file immediately after submission, however it turns out the docn file is written for a second time when the job starts.

I wonder if anyone knows how to solve this.

Best,

Wenyu
 
I am not able to download the '../ocn/docn7/AQUAPLANET/sst_c4aquasom_0.9x1.25_clim.c170512.nc' file. ftp or wget cannot find the .nc file or the AQUAPLANET directory in the server. Please suggest. Or may be upload the file if not too much trouble.
I am trying with > ./check_input_data --download
 
Top