Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Prevent the NaN in the model run

arti-14

Arti Jadav
New Member
Hi,

I am simulating a case in the SCAM model, and I have added a subroutine in the Zhang-Macfarlane microphysics.

I am getting NaN values in the output, after the addition of the subroutine. Is there a way to add an argument (-ftrapuv) in the .cime (config_compilers.xml), which would prevent the propogation of the NaNs in the model run.

Thank you in advance for the help

Best Regards,
Arti Jadav
 

erik

Erik Kluzek
CSEG and Liaisons
Staff member
These kind of things are usually turned on when you set DEBUG=TRUE in the env_build.xml file for your case.
Check the Macros.make file and you'll see some of the settings for your case. This depends on the compiler and machine you are using.
 
Top