Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

problem running under BASH shell


From Mike Dvorak:

I've been running CCSM3.0 on the Argonne Jazz cluster recently. I had a lot of
problems getting CCSM to run when my shell was set to bash. I was getting
errors along the lines of "logname not found" and "LOGNAME not found" in some of
the component model log files.

Finally, I switched my default shell to tcsh and it worked. I think the problem
is that you are using "#! /bin/csh -f" in the $CASENAME.$MACH.run files. The
"-f" options doesn't acquire all of the environment you would expect. I changed
the line to "#! /bin/tcsh" this afternoon and was able to submit the jobs under
the bash environment (I assume just "#! /bin/csh" would work the same way).

Is there some way you can just get rid of that "-f" option, at least for the
Jazz configuration?


We are not supporting bash shell. The reason that the -f option appears
in the shell scripts is so that settings in the user's .cshrc file will
not conflict with possible environment variable settings in the scripts.
You are free to remove this for his runs - but we do not plan to
officially support anything but csh in the scripts for now.


CSEG and Liaisons
Staff member
I believe that you can use bash or another shell. You just need to have a .cshrc file in place.


New Member
Although it might be possible to run the CCSM scripts from a shell other than csh, some users may not be able to set this up on their own. Getting the CCSM scripts to run on all supported platforms with csh (and perl) has proven tougher than you might imagine. CSH is not the same on every platform (scripts written that worked on early machines did not always work on additional machines). Our regression testing requirement and limited staff forced us to choose one. We chose csh.