Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Running the predefined tests in an sgi IRIX64

Hi All,

I am new to CCSM and I am trying to compile and run the predefined test before creating new cases. My machine is an 8 processor sgi IRIX64 which I think (and hope) falls in the list of supported systems. I appears to me that it somehow similar to chinook which is in the supported list.

I am testing the first test in section 7.3 of the manual.

The compilation appers to be succesful, the problem is when I try to run it.

The message that I get is

(shr_msg_chdir) read atm_stdio.nml, changed cwd to
MPI: MPI_COMM_WORLD rank 15 has terminated without calling MPI_Finalize()
MPI: aborting job
MPI: Received signal 10

[1] Exit 1 mpirun -v -d /home/hoyos/SCRATCH/TER.01a.T31_gx3v5.B.generic_sgi.112920/all -np ...
Tue Oct 5 10:50:34 EDT 2004 -- CSM EXECUTION HAS FINISHED
Model did not complete - see cpl.log.041005-105010

Anyone has an idea on how could I solve this problem?

Thanks a lot!!!



Note I have moved your post to the forum for porting to new machines since it belongs in that category. An SGI is one of the machines we are playing with but
do not currently support. Any support would actually have to come in a new
CCSM update.

I have asked our porting expert to view your question to see if he has any quick recommendations. There have been other individuals involved with trying to port to SGIs, and you may get assistance from them once this bullitan board gets off the ground. Our official announcement went out this afternoon.

In the meantime, I ask your paitence as we try to extend CCSM 3.0's capabilities to new architectures.

Thanks for you answer.
I wanted to add mnore information about our system. We are using a SGI Origin 300 running IRIX 6.5. We think this is very close to chinook but as I mentioned before we have problems running the tests. We are able to build them but not run them.

Is there a way to turn off mpi and use OpenMP only?


New Member
I do not know if all OMP worked on chinook. Chinook is not a machine I can run on anymore. Most of the work preceeded by tenure. Perhaps another will be able to answer the main question. I did run some hybrid tests (mixed mpi and omp) previously on Chinook. The results indicated that in all cases but one, pure mpi was faster than any of the hybrid configurations I tried. In the one case, it was a wash ... no clear winner.