Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

WRF-CTSM configuration problem

negins

Negin Sobhani
Moderator
Staff member
Hello,
There are two distinct steps here that should not be confused with each other:
The first step is ./configure (without any em_real). Here you choose the option you'd like to compile with. For example, option 15 if you are compiling with intel compiler (as in the example provided).
After successfully configuring then you do ./compile em_real >& compile.log. The ./compile is in your WRF cloned repository (WRF directory).

If you've already logged out of your Cheyenne node make sure to load the correct environment and modules before configuring and compiling WRF by :
source ctsm_build_dir/ctsm_build_environment.csh
setenv WRF_CTSM_MKFILE /glade/scratch/$USER/WRF-CTSM/CTSM/ctsm_build_dir/bld/ctsm.mk
Please make sure this above path is correct and it is where you built your ctsm library.

Please follow the instructions here and let me know if this does not solve your problem.
 

maruf2812

Montasir Maruf
Member
Hi,

Thank you for your reply. I followed all the instruction carefully. First I set the environment and run .configure. But when I am trying to run ./compile it did not work..I have attached the error message. Capture.JPG
 

negins

Negin Sobhani
Moderator
Staff member
Thanks for your message. I cannot understand the error message unless I see the whole log. The last lines of the error message as you see does not give much information to us. One thing you can do is to search for the word "Error" in the log file. For example, if you compile in the compile.log look for Error and paste it here. Usually, the first occurrence of Error is where we should look at.

Are you trying to compile this on Cheyenne? If so, can you please point to your directory?

Thanks!
Negin
 

maruf2812

Montasir Maruf
Member
Hi,

Thank you for the help. It works. I have downloaded the WPS file. Could you please tell me how to untar it on Cheynne since untar and unzip are not working here.

Capture.JPG
 

negins

Negin Sobhani
Moderator
Staff member
Hello!
It is great that it is working.

For unpacking any tar file just use the tar command.
For example the following for your case:
tar -xvf WPSV4.0.TAR.gz

Please note that for the example case in the documentation you don't need WPS and you can run the example case without using WPS.

If you are interested in knowing more about WPS, I'd recommend reading WRF user guide : https://www2.mmm.ucar.edu/wrf/users/docs/user_guide_V3.9/ARWUsersGuideV3.9.pdf

Thanks!
Negin
 

maruf2812

Montasir Maruf
Member
Thank you! So I don't need WPS folder if I want to use WRF-CTSM on Cheyenne? Can I run a simulation without geogrid.exe, ungrib.exe and metgrid.exe?
 

negins

Negin Sobhani
Moderator
Staff member
If you are interested in running the test case (example case) you don't need to compile WPS and run geogrid, ungrib and metgrid. But if you are setting up your own domain for your simulation, then you need to complete WPS steps to get WRF initial and boundary conditions.

For the example case on the documentation webpage, we provided these files.
 

maruf2812

Montasir Maruf
Member
I am trying to compile WPS. For configure I choose option 19. This error showed up when I compile WPS.

Capture.JPG
 

negins

Negin Sobhani
Moderator
Staff member
Hello!
The error message you are getting is the following:

Error : Not building geogrid. Check whether WRF is compiled in /glade/u/home/maruf/WRF-CTSM/WPS/../WRFV3

Which means have you successfully compiled WRF in /glade/u/home/maruf/WRF-CTSM/WPS/../WRFV3?

I specifically looked at your case where you successfully compiled WRF but it is in the folder named WRF-CTSM, not WRFV3.

For resolving this issue you can do the following:

./clean -a
./configure

In the file configure.wps change the WRF_DIR line to the following:

WRF_DIR = ../../WRF-CTSM

and then compile WPS again.

This should resolve the problem with compiling WPS.
 

maruf2812

Montasir Maruf
Member
Thank you Negin that works perfectly. I am just wondering which data to use for WRF-CTSM land model run. I heard that the data comes with the installed package. I completed the geogrid. Now for ungrib, I am looking for the data directory.
 
Top