Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

branch run error: (ocn_import): qsw aggregation mismatch exceeds threshold

chrysan17

New Member
Hello,
I intend to run G compset(only pop) for 100 years first, then turn on MARBL component from 101th year for the subsequent simulation, in order to shorten spin-up time.
So I try to do a branch run at 101th year.

First I run G compset(no MARBL) for 100 years to get restart files(CASE1);
And I run G compset(include MARBL ) for only several years to get restart files(CASE2);
Then I modify the restart files of CASE1(*.pop.r.* and *.cpl.r.* ), extract the fields of biogeochemical variables from the restart files in CASE2 and write into the restart files of CASE1.

But I always get an error when I submit a branch run, the cesm.log content as follows:

MCT::m_Router::initp_: GSMap indices not increasing...Will correct
qsw aggregation mismatch exceeds threshold i_glob=209 j_glob=3 qsw_col_dagg_1pt=-0.322820E-02 qsw_bin_dagg_1pt=-0.322820E-02
ERROR: Error: (ocn_import): qsw aggregation mismatch exceeds threshold
qsw aggregation mismatch exceeds threshold i_glob=217 j_glob=6 qsw_col_dagg_1pt=-0.436082E+00 qsw_bin_dagg_1pt=-0.436082E+00
ERROR: Error: (ocn_import): qsw aggregation mismatch exceeds threshold
.......
qsw aggregation mismatch exceeds threshold i_glob=315 j_glob=4 qsw_col_dagg_1pt=-0.717677E+01 qsw_bin_dagg_1pt=-0.717677E+01
ERROR: Error: (ocn_import): qsw aggregation mismatch exceeds threshold
Image PC Routine Line Source
cesm.exe 000000000123027A Unknown Unknown Unknown
cesm.exe 0000000000D74A10 shr_abort_mod_mp_ 114 shr_abort_mod.F90
cesm.exe 0000000000A24875 mcog_mp_import_mc 665 mcog.F90
cesm.exe 0000000000740A6D ocn_import_export 312 ocn_import_export.F90
cesm.exe 0000000000736B6A ocn_comp_mct_mp_o 632 ocn_comp_mct.F90
cesm.exe 0000000000435D30 component_mod_mp_ 728 component_mod.F90
cesm.exe 000000000041BA06 cime_comp_mod_mp_ 3423 cime_comp_mod.F90
cesm.exe 0000000000435977 MAIN__ 125 cime_driver.F90
cesm.exe 0000000000417EA2 Unknown Unknown Unknown
libc-2.17.so 00002B43EF9C9555 __libc_start_main Unknown Unknown
cesm.exe 0000000000417DA9 Unknown Unknown Unknown

I wonder if it's acceptable to spinup in this way? What's the reason for this error?
Any suggestions or help are highly appreciated. Thank you so much!
 
Top