Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Error when creating new case: Could not find machine match for

xcj

xcj
New Member
I will do that. In the meantime, is there no way I can simply modify the path so that it fetches the config_machines.xml from $HOME/.cime/ instead of /cvmfs/soft.computecanada.ca/easybuild/software/2017/Core/cesm/2.1.1/ without porting the model myself?
 

jedwards

CSEG and Liaisons
Staff member
That is what should happen. Nether of us understand why it isn't happening. I'm not sure what more I can do with that.
 

xcj

xcj
New Member
Going back to testing CIME as described here: 8. Testing — CIME master documentation, I tried

$CIMEROOT/scripts/create_test test

and got the error:

File "/cvmfs/soft.computecanada.ca/gentoo/2020/usr/lib/python3.7/sre_parse.py", line 645, in _parse


source.tell() - here + len(this))


re.error: nothing to repeat at position 0

 

xcj

xcj
New Member
Hello again, I tried running create_test test and I keep getting the unknown machine error. I validated all three config files:

xmllint --noout --schema $CESM_ROOT/cime/config/xml_schemas/config_machines.xsd $HOME/.cime/config_machines.xml



xmllint --noout --schema $CESM_ROOT/cime/config/xml_schemas/config_compilers_v2.xsd $HOME/.cime/config_compilers.xml



xmllint --noout --schema $CESM_ROOT/cime/config/xml_schemas/config_batch.xsd $HOME/.cime/config_batch.xml

and they all checked out, so why can't the model find my machine?
 
Top