Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

pio_support::pio_die:: myrank= -1 : ERROR: pionfget_mod.F90: in some F*case

xiaxs

xiaxs
New Member
Dear everyone:
I have got the same error in some F* case (such as FWHIST_BGC, FWmaHist-BGC andFCfireHIST), even if run with default, the error is pio_support::pio_die:: myrank= -1 : ERROR: pionfget_mod.F90:.
my cesm release is 2.1.3, my machine plateform is tianhe2. my case is ./create_newcase --compset FWHIST_BGC --res f09_f09_mg17 --case ~/CESM2/scratch/FWHIST_BGCtest. the information of create_newcase, setup, build and submit had been saved as log files. and other log files will be provided as follows. any help and advice will be appreciate! Thank you!

here is my main code:

./xmlchange NTASKS=120
./xmlchange NTASKS_ESP=5

vim user_nl_clm
hist_empty_htapes = .true
hist_avgflag_pertape = 'A'
hist_nhtfrq = 0
hist_mfilt = 1
hist_fincl1="QOVER","QH2OSFC","H2OSOI","GPP","NPP","NEP","TLAI","FLDS","FSDS","Rnet","QVEGT","QSOIL","QINTR","FSH","TSA","Q2M"
```

./xmlchange DOUT_S=TRUE
./xmlchange JOB_WALLCLOCK_TIME=12:00:00
./xmlchange STOP_N=3,STOP_OPTION=nmonths
 

Attachments

  • atm.log.txt
    222.4 KB · Views: 1
  • CaseStatus.txt
    2.2 KB · Views: 0
  • cesm.log.txt
    99.8 KB · Views: 3
  • cpl.log.txt
    43.5 KB · Views: 0
  • FWHIST_BGCtest.build.txt
    5.3 KB · Views: 1
  • FWHIST_BGCtest.create_newcase.txt
    3.5 KB · Views: 0
  • FWHIST_BGCtest_submit.txt
    4.6 KB · Views: 0

mlevy

Michael Levy
CSEG and Liaisons
Staff member
From cesm.log.txt, I am noticing

Code:
001:  Opened existing file
001:  /BIGDATA1/sysu_syli_3/CESM2/inputdata/atm/cam/chem/stratvolc/VolcanEESMv3.11_SO
001:  2_850-2016_Mscale_Zreduc_1deg_c180812.nc     6356992
001:  Opened existing file
001:  /BIGDATA1/sysu_syli_3/CESM2/inputdata/atm/cam/chem/stratvolc/VolcanEESMv3.11_SO
001:  2_850-2016_Mscale_Zreduc_1deg_c180812.nc     6356992
001:  NetCDF: HDF error

I am not familiar with this error, but it is possible the netCDF file is corrupt. Can you check the 256-bit SHA sum? I ran the following:

Code:
$ shasum --a 256 VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc
eb6d83586242c9e72b74df416ee8e7975b4bf620d0e3aaa490155f4f1dbd2b1e  VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc

According to the logs, this file is in /BIGDATA1/sysu_syli_3/CESM2/inputdata/atm/cam/chem/stratvolc/ on your machine. If your output does not match the eb6d83586242c9e72b74df416ee8e7975b4bf620d0e3aaa490155f4f1dbd2b1e string then you should delete it and let CESM try to download it again. (It is a large file, ~8.5 GB, so perhaps something happened that interrupted the download the first time?)

If that doesn't work, I will move this ticket to the atmosphere modelling forum because it looks like the error is being triggered from CAM.
 

xiaxs

xiaxs
New Member
Dear Michael,

Thank you for reply! I have check the shasum of VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc. It is coorect.

[sysu_syli_3@lon26%tianhe2-H stratvolc]$ shasum --a 256 VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc
eb6d83586242c9e72b74df416ee8e7975b4bf620d0e3aaa490155f4f1dbd2b1e VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc
 

mlevy

Michael Levy
CSEG and Liaisons
Staff member
I've moved this to the CAM-Chem forum because the traceback in cesm.log.txt passes through chemistry.F90. I think this might still be a corrupt file issue - does anyone in this forum know what file is read after VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc? We should compare SHAs on that file as well.

Code:
001: Image              PC                Routine            Line        Source
001: cesm.exe           00000000028D386A  Unknown               Unknown  Unknown
001: cesm.exe           000000000278E28D  pio_support_mp_pi         118  pio_support.F90
001: cesm.exe           000000000278CBD6  pio_utils_mp_chec          74  pio_utils.F90
001: cesm.exe           00000000027D0A53  pionfget_mod_mp_g         426  pionfget_mod.F90.in
001: cesm.exe           0000000000EBAEDC  tracer_data_mp_op        1902  tracer_data.F90
001: cesm.exe           0000000000ED3690  tracer_data_mp_tr         280  tracer_data.F90
001: cesm.exe           00000000011DAA17  mo_extfrc_mp_extf         304  mo_extfrc.F90
001: cesm.exe           00000000011B3FD5  mo_chemini_mp_che         166  mo_chemini.F90
001: cesm.exe           00000000010317C9  chemistry_mp_chem         882  chemistry.F90
001: cesm.exe           00000000006A35EE  physpkg_mp_phys_i         822  physpkg.F90
001: cesm.exe           00000000004FF69D  cam_comp_mp_cam_i         201  cam_comp.F90
001: cesm.exe           00000000004F8A52  atm_comp_mct_mp_a         209  atm_comp_mct.F90
001: cesm.exe           000000000044056F  component_mod_mp_         267  component_mod.F90
001: cesm.exe           000000000042ED3F  cime_comp_mod_mp_        1231  cime_comp_mod.F90
001: cesm.exe           000000000043D5E7  MAIN__                    114  cime_driver.F90
001: cesm.exe           000000000041E7DE  Unknown               Unknown  Unknown
001: libc-2.17.so       00002ACAF8D8EB35  __libc_start_main     Unknown  Unknown
001: cesm.exe           000000000041E6E9  Unknown               Unknown  Unknown
 

mlevy

Michael Levy
CSEG and Liaisons
Staff member
One other possibility -- I noticed that this file is in the netCDF-4 format:

Code:
$ ncdump -k VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc
netCDF-4 classic model

I've run into issues on the NCAR supercomputer where some compilers have built the netCDF library in such a way that these files can not be read. The error I was seeing in that case was

Code:
NetCDF: Attempt to use feature that was not turned on when netCDF was built.

and the ncdump -k command returned netCDF-4 rather than netCDF-4 classic model... so I doubt that is the problem you are running into, but another thing to try would be

Code:
$ mv VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc old-VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc
$ ncks -5 old-VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc

and then ncdump -k VolcanEESMv3.11_SO2_850-2016_Mscale_Zreduc_1deg_c180812.nc should return cdf5. (ncks is part of nco, hopefully that package is available on your machine. If not, I believe nccopy -5 will also work.)
 
Top