Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

Port to a new XC50

swartn

Neil Swart
New Member
Hello,

I'm trying to port to a new XC50. I build a machine_config.xml, based on aleph, which is very similar. Where I'm currently struggling is in the correct definition of `config_batch.xml`. The system also uses pbs, however there are some details about the queues. I tried to define a version in `$HOME/.cime/config_batch.xml`, using the pbs definitions from the default `.cime/config/cesm/machines/config_batch.xml`, however when I test the syntax on this (exact same file) it does not validate.

If I have no `config_batch.xml` file, when using `create_newcase`, I get an error, even if I explicitly specify the queue and wallclock time to use:

```
./create_newcase --case ~/runpath3/my_cesm_sandbox/test/b.e20.B1850.f19_g17.test --compset B1850 --res f19_g17 -q development --walltime 03:00:00
WARNING: No queue on this system met the requirements for this job. Falling back to defaults
ERROR: No queues found
```

Any guidance on correctly defining the `config_batch`, selecting specific queues, or other necessary machine configuration? thanks
 

swartn

Neil Swart
New Member
Sorry, I should correct that. The default `config_batch` does validate, but I still have the issue regarding selecting a queue.
 
Top