Welcome to the new DiscussCESM forum!
We are still working on the website migration, so you may experience downtime during this process.

Existing users, please reset your password before logging in here: https://xenforo.cgd.ucar.edu/cesm/index.php?lost-password/

BUILD FAIL: pop.buildlib failed (trouble in porting cesm2.1.1)

majun

Member
Dear all,
Now , I am porting cesm2.1.1 to centos6, however there was some trouble:
I use the command as follows:
(1) ./create_newcase --case test_case --res f19_g17 --compset B1850 --mach majun
(2) ./case.setup
(3)./case.build
error occurs in the step "./case.build", it shows:
ERROR: BUILD FAIL: pop.buildlib failed, cat /home/shenhf/majun/mycesm/output/case1/bld/ocn.bldlog.200103-090406
the bldlog file shows :
ERROR: Command make complib -j 1 MODEL=pop COMPLIB=/home/shenhf/majun/mycesm/output/case1/ bld/lib/libocn.a -f /home/shenhf/majun/mycesm/cime/scripts/case1/Tools/Makefile USER_CPPDEFS="-DCCSMCOUPLED -DMARBL_TIMING_OPT=CIME -DBLCKX=80 -DBLCKY=96 -DMXBLCKS=1 - DNT=37 -DMARBL_NT=32 -DIRF_NT=0 " failed rc=2
Do you know what's the problem ? the brief configurations are:
gcc -8.3.0 / netcdf-4.7.3 / hdf5-1.8.20 / mpich-3.3.1 /python-2.7.17 /pnetcdf-1.12.0 /esmf_8.0.0 / curl-7.20.0 /bison-3.0.5 /lapack-3.4.2
compilers are gcc and gfortran, and I didn't use moudles and batch system.
In fact, I just want to use clm5.0 component in cesm2.1 and don't care about other components, like pop ,cam .etc. The log file , config_compilers.xml config_machines.xml and screenshot of esmf are attached below, any suggestions or help are highly appreciated.
 

Attachments

  • ocn.bldlog.200103-090406.txt
    171.1 KB · Views: 4
  • config_compilers.txt
    39.9 KB · Views: 2
  • config_machines.txt
    98.3 KB · Views: 1
  • ESMF.png
    ESMF.png
    78.1 KB · Views: 2

sacks

Bill Sacks
CSEG and Liaisons
Staff member
You say you are just trying to use clm5.0. Is your eventual plan to do a fully-coupled run (B compset), or are you just doing that for testing? If all you want is to do a standalone land run, then you can test the port with an I compset (e.g., I1850Clm50BgcCrop).

If you do need to run a B compset, then can you please document the version of code you are using: give the output from running the following commands from the top level of your CESM clone (that is, run these from the directory containing cime, components, etc.):
  • git describe
  • ./manage_externals/checkout_externals --status --verbose
 

majun

Member
You say you are just trying to use clm5.0. Is your eventual plan to do a fully-coupled run (B compset), or are you just doing that for testing? If all you want is to do a standalone land run, then you can test the port with an I compset (e.g., I1850Clm50BgcCrop).

If you do need to run a B compset, then can you please document the version of code you are using: give the output from running the following commands from the top level of your CESM clone (that is, run these from the directory containing cime, components, etc.):
  • git describe
  • ./manage_externals/checkout_externals --status --verbose
thanks a lot , I will have a try
 
Top